curl-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.62.0
  9. Release: 1%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: http://curl.haxx.se/
  13. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # patch making libcurl multilib ready
  15. Patch101: 0101-curl-7.32.0-multilib.patch
  16. # prevent configure script from discarding -g in CFLAGS (#496778)
  17. Patch102: 0102-curl-7.36.0-debug.patch
  18. # migrate tests/http_pipe.py to Python 3
  19. Patch103: 0103-curl-7.59.0-python3.patch
  20. # use localhost6 instead of ip6-localhost in the curl test-suite
  21. Patch104: 0104-curl-7.19.7-localhost6.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: openssl-devel
  24. BuildRequires: gnutls-devel
  25. BuildRequires: libidn-devel zlib-devel
  26. BuildRequires: openldap-devel
  27. BuildRequires: openssh-server
  28. BuildRequires: openssh-clients
  29. BuildRequires: pkgconfig
  30. %if "%{?_dist_release}" != "vl6"
  31. BuildRequires: libssh2-devel
  32. %endif
  33. %if 0%{?with_http2}
  34. BuildRequires: libnghttp2-devel
  35. %endif
  36. Requires: ca-certificates
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. Packager: daisuke
  40. %description
  41. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  42. Dict servers, using any of the supported protocols. cURL is designed
  43. to work without user interaction or any kind of interactivity. cURL
  44. offers many useful capabilities, like proxy support, user
  45. authentication, FTP upload, HTTP post, and file transfer resume.
  46. %package devel
  47. Summary: Files needed for building applications with libcurl.
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. Requires: openssl-devel libidn-devel zlib-devel
  51. %description devel
  52. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  53. Dict servers, using any of the supported protocols. The curl-devel
  54. package includes files needed for developing applications which can
  55. use cURL's capabilities internally.
  56. #'
  57. ## to build compat32 for x86_64 architecture support
  58. %package -n compat32-%{name}
  59. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  60. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  61. Group: System Environment/Libraries
  62. %description -n compat32-%{name}
  63. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  64. Dict servers, using any of the supported protocols. cURL is designed
  65. to work without user interaction or any kind of interactivity. cURL
  66. offers many useful capabilities, like proxy support, user
  67. authentication, FTP upload, HTTP post, and file transfer resume.
  68. %package -n compat32-%{name}-devel
  69. Summary: Files needed for building applications with libcurl.
  70. Group: Development/Libraries
  71. %description -n compat32-%{name}-devel
  72. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  73. Dict servers, using any of the supported protocols. The curl-devel
  74. package includes files needed for developing applications which can
  75. use cURL's capabilities internally.
  76. #'
  77. %prep
  78. %setup -q
  79. # upstream patches
  80. # (none)
  81. # Fedora patches
  82. %patch101 -p1
  83. %patch102 -p1
  84. #patch103 -p1
  85. %patch104 -p1
  86. # make tests/*.py use Python 3
  87. sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
  88. # regenerate Makefile.in files
  89. aclocal -I m4
  90. automake
  91. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  92. # with errno 98: Address already in use' in Koji environment), and test 1801
  93. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  94. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  95. # <https://github.com/curl/curl/pull/2705>
  96. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  97. # disable test 1319 on ppc64 (server times out)
  98. %ifarch ppc64
  99. echo "1319" >> tests/data/DISABLED
  100. %endif
  101. # temporarily disable test 582 on s390x (client times out)
  102. %ifarch s390x
  103. echo "582" >> tests/data/DISABLED
  104. %endif
  105. # adapt test 323 for updated OpenSSL
  106. sed -e 's/^35$/35,52/' -i tests/data/test323
  107. %build
  108. %configure \
  109. --with-ssl=%{_prefix} \
  110. --with-libidn \
  111. --enable-ipv6 \
  112. --enable-threaded-resolver \
  113. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  114. %if "%{?_dist_release}" != "vl6"
  115. --with-libssh2 \
  116. %endif
  117. %if 0%{?with_http2}
  118. --with-nghttp2 \
  119. %endif
  120. --enable-ldaps \
  121. --disable-static \
  122. --enable-hidden-symbols
  123. make %{?_smp_mflags}
  124. %install
  125. rm -rf $RPM_BUILD_ROOT
  126. make DESTDIR=$RPM_BUILD_ROOT install
  127. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  128. %clean
  129. rm -rf $RPM_BUILD_ROOT
  130. %post -p /sbin/ldconfig
  131. %postun -p /sbin/ldconfig
  132. %files
  133. %defattr(-,root,root)
  134. %{!?_licensedir:%global license %%doc}
  135. %license COPYING
  136. %doc CHANGES README
  137. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  138. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  139. %doc docs/TheArtOfHttpScripting docs/TODO
  140. %{_bindir}/curl
  141. #{_datadir}/curl/*
  142. %{_libdir}/*.so.*
  143. %{_mandir}/man1/*.1*
  144. %files devel
  145. %defattr(-,root,root)
  146. %{_bindir}/curl-config
  147. %{_includedir}/curl
  148. %{_libdir}/*.so
  149. %{_libdir}/pkgconfig/*.pc
  150. %{_mandir}/man1/curl-config.1*
  151. %{_mandir}/man3/*
  152. %{_datadir}/aclocal/libcurl.m4
  153. ## to build compat32 for x86_64 architecture support
  154. %if %{build_compat32}
  155. %files -n compat32-%{name}
  156. %defattr(-,root,root)
  157. %{_libdir}/*.so.*
  158. %files -n compat32-%{name}-devel
  159. %defattr(-,root,root)
  160. %{_libdir}/*.so
  161. %{_libdir}/pkgconfig/*.pc
  162. %endif
  163. %changelog
  164. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  165. - new upstream release.
  166. - imported patches from rawhide.
  167. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  168. - new upstream release.
  169. - imported Patch1 and 103 from rawhide.
  170. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  171. - new upstream release with security fix
  172. - update patch101
  173. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  174. - new upstream release.
  175. - updated Patch101-104.
  176. - dropped Patch107.
  177. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  178. - new upstream release.
  179. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  180. - new upstream release.
  181. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  182. - new upstream release.
  183. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  184. - new upstream release.
  185. - disabled HTTP/2 on Vine6.
  186. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  187. - added HTTP/2 support.
  188. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  189. - new upstream release with security fix.
  190. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  191. - new upstream release.
  192. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  193. - new upstream release
  194. - built with openssl 1.0.2g
  195. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  196. - new upstream release with security fix .
  197. - removed Patch108 (fixed in upstream).
  198. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  199. - new upstream release with security fix
  200. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  201. - new upstream release
  202. - add libcurl.m4 to -devel package
  203. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  204. - new upstream release
  205. - import upstream/fedora patches
  206. - disable libssh2 on Vine Linux 6
  207. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  208. - new upstream reelase
  209. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  210. - update to 7.28.0
  211. - add configure options
  212. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  213. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  214. - use ca-certificates package
  215. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  216. - R: ca-certificates
  217. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  218. - new upstream release
  219. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  220. - add patch100 for fix CVE-2011-2192 (gssapi)
  221. - add Vendor/Distri tags
  222. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  223. - rebuild with openssl-1.0.0c
  224. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  225. - rebuilt with rpm-4.8.1 for pkg-config
  226. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  227. - new upstream release
  228. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  229. - new upstream release with security fix
  230. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  231. - added compat32 subpackages
  232. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  233. - new upstream release
  234. - use "_smp_mflags" flag
  235. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  236. - rebuild with openldap-2.4.11
  237. - add BR: openldap-devel
  238. - remove static library
  239. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  240. - new upstream release with security fix (CVE-2009-0037)
  241. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  242. - new upstream release
  243. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  244. - new upstream release
  245. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  246. - new upstream release
  247. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  248. - new upstream release
  249. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  250. - new upstream release
  251. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  252. - rebuilt with openssl-0.9.8e
  253. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  254. - new upstream release
  255. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  256. - new upstream release
  257. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  258. - new upstream release
  259. - add pkgconfig file to devel package
  260. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  261. - new upstream release
  262. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  263. - new upstream release
  264. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  265. - new upstream release
  266. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  267. - added libidn, zlib in Requires
  268. - added libidn-devel, zlib-devel in BuildPrereq
  269. - added zlib-devel in curl-devel's Requires
  270. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  271. - added openssl-devel, libidn-devel in curl-devel's Requires
  272. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  273. - new upstream release
  274. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  275. - new upstream release
  276. - rebuild with openssl-0.9.7d
  277. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  278. - upstream release
  279. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  280. - add %%{_datadir}/curl/* to %%files section
  281. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  282. - source upgrade
  283. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  284. - source upgrade
  285. - add PreReq: ldconfig
  286. - add %%{_libdir}/*.la to %%files devel section
  287. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  288. - build for VineSeed
  289. - add Requires: openssl
  290. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  291. - automated rebuild
  292. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  293. - 7.9.2
  294. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  295. - include curl-config in curl-devel
  296. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  297. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  298. - added openssl-devel build req
  299. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  300. - built for the distro
  301. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  302. - upgrade to curl-7.7.2.
  303. - enable IPv6.
  304. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  305. - rebuilt against openssl-0.9.6-1
  306. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  307. - fixed mising ldconfigs
  308. - updated to 7.5.2, bug fixes
  309. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  310. - updated to 7.5.1
  311. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  312. - update to 7.4.1 to fix bug #20337, problems with curl -c
  313. - not using patch anymore, it's included in the new source. Keeping
  314. for reference
  315. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  316. - fix bogus req in -devel package
  317. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  318. - devel package needed defattr so that root owns the files
  319. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  320. - update to 7.3
  321. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  322. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  323. - enable SSL support
  324. - fix packager tag
  325. - move buildroot to %%{_tmppath}
  326. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  327. - fixed vendor tag for bug #15028
  328. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  329. - rebuilt
  330. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  331. - workaround alpha build problems with optimizations
  332. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  333. - rebuilt
  334. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  335. - put man pages in correct place
  336. - use %%makeinstall
  337. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  338. - updated to 6.5.2
  339. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  340. - updated sources to 6.2
  341. - gzip man page
  342. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  343. - changed group
  344. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  345. - changelog started
  346. - general cleanups, changed prefix to /usr, added manpage to files section
  347. - including in Powertools