PyQt4-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  2. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  4. %global sip_ver %(sip -V 2>/dev/null | cut -d' ' -f1 | cut -d- -f1)
  5. # Qt4 version auto-detection -- inagaki
  6. %define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.7.1)
  7. %define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
  8. Name: PyQt4
  9. Summary: Python bindings for Qt4
  10. Summary(ja): Qt4 の Python バインディング
  11. Version: 4.8.3
  12. Release: 1%{?_dist_release}
  13. # GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
  14. License: GPLv3 or GPLv2 with exceptions
  15. Group: Development/Languages
  16. URL: http://www.riverbankcomputing.com/software/pyqt/
  17. Source0: http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-%{version}.tar.gz
  18. Patch1: PyQt-x11-gpl-4.4.4-64bit.patch
  19. # HACK! FIXME: ping upstream why this isn't working right. -- Rex
  20. Patch2: PyQt-x11-gpl-4.5.2-QT_SHARED.patch
  21. Patch4: PyQt-x11-gpl-4.5.1-pyuic_shebang.patch
  22. # Vine Patch
  23. Patch100: PyQt-x11-gpl-4.7.3-phononpath_vine.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. #BuildRequires: chrpath
  26. BuildRequires: dbus-devel dbus-python-devel
  27. BuildRequires: findutils
  28. BuildRequires: phonon-devel
  29. # beware of PyQt4/qscintilla bootstap issues
  30. #BuildRequires: qscintilla
  31. BuildRequires: qt4-devel >= 4.5.0
  32. BuildRequires: python-devel
  33. BuildRequires: sip-devel >= 4.9
  34. BuildRequires: libXext-devel
  35. Requires: sip >= %{sip_ver}
  36. Requires: dbus-python
  37. Requires: qt4 >= %{qtver}
  38. %description
  39. These are Python bindings for Qt4.
  40. %package devel
  41. Summary: Files needed to build other bindings based on Qt4
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: qt4-devel >= %{qtver}
  45. Requires: sip-devel >= 4.9
  46. %description devel
  47. Files needed to build other bindings for C++ classes that inherit from any
  48. of the Qt4 classes (e.g. KDE or your own).
  49. %prep
  50. %setup -q -n PyQt-x11-gpl-%{version}
  51. #patch1 -p1 -b .64bit
  52. %patch2 -p1 -b .QT_SHARED
  53. #patch4 -p1
  54. %patch100 -p1 -b .phononpath_vine
  55. ## permissions
  56. # mark examples non-executable
  57. find examples/ -name "*.py" | xargs chmod a-x
  58. chmod a+rx pyuic/uic/pyuic.py
  59. %build
  60. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  61. CFLAGS="${CFLAGS:-%optflags}" \
  62. CXXFLAGS="${CXXFLAGS:-%optflags} -I%{_includedir}/KDE" \
  63. %{__python} configure.py \
  64. --confirm-license \
  65. --qmake=%{qt4qmake} \
  66. --no-qsci-api \
  67. --verbose
  68. make %{?_smp_mflags}
  69. %install
  70. rm -rf $RPM_BUILD_ROOT
  71. make install DESTDIR=$RPM_BUILD_ROOT INSTALL_ROOT=$RPM_BUILD_ROOT
  72. # HACK: fix multilb conflict, http://bugzilla.redhat.com/509415
  73. rm -fv $RPM_BUILD_ROOT%{_bindir}/pyuic4
  74. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py \
  75. $RPM_BUILD_ROOT%{_bindir}/pyuic4
  76. ln -s %{_bindir}/pyuic4 \
  77. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pyuic.py
  78. %clean
  79. rm -rf $RPM_BUILD_ROOT
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc NEWS README
  83. %doc OPENSOURCE-NOTICE.TXT
  84. %doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
  85. %doc LICENSE.GPL3
  86. %{python_sitearch}/PyQt4/
  87. %exclude %{python_sitearch}/PyQt4/uic/pyuic.py*
  88. # fixme? -> sitearch? -- Rex
  89. %{python_sitelib}/dbus/mainloop/qt.so
  90. %{_libdir}/qt-%{qtver}/plugins/designer/*
  91. %files devel
  92. %defattr(-,root,root,-)
  93. %doc doc/*
  94. %doc examples/
  95. %{_bindir}/pylupdate4
  96. %{_bindir}/pyrcc4
  97. %{_bindir}/pyuic4
  98. %{python_sitearch}/PyQt4/uic/pyuic.py*
  99. %{_datadir}/sip/PyQt4/
  100. #{_qt4_prefix}/qsci/api/python/PyQt4.api
  101. %changelog
  102. * Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.8.3-1
  103. - new upstream release
  104. - built with sip-4.12.1 and qt4-4.7.1
  105. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.4-2
  106. - rebuild with qt4-4.6.3
  107. - fix %qtver (from 4.6.1 to 4.6.3)
  108. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.4-1
  109. - new upstream release
  110. - rebuilt with sip-4.10.5 and qt4-4.6.3
  111. * Sun May 09 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.3-1
  112. - new upstream release
  113. - updated Patch100
  114. * Fri Feb 05 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7-2
  115. - updated Patch100 to build phonon module
  116. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 4.7-1
  117. - new upstream release
  118. - rebuilt with python-2.6.4
  119. - dropt Patch100: PyQt-x11-gpl-4.5.4-vine_phonon.patch
  120. * Fri Oct 23 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6-2
  121. - now BuildRequires sip-devel >= 4.9 (was 4.8.2)
  122. * Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 4.6-1
  123. - new upstream release
  124. - added BR: libXext-devel
  125. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-3
  126. - added Patch100 for building phonon modules
  127. * Tue Aug 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.5.4-2
  128. - Initial build for Vine
  129. * Tue Jul 28 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.4-1
  130. - PyQt4-4.5.4
  131. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.5.2-2
  132. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  133. * Thu Jul 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-1
  134. - PyQt4-4.5.2
  135. * Thu Jul 02 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
  136. - fix build with qt-4.5.2
  137. - PyQt4-devel multilib conflict (#509415)
  138. * Tue Jun 16 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-1
  139. - PyQt-4.5.1
  140. * Fri Jun 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-1
  141. - PyQt-4.5
  142. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.2.20090520
  143. - fix generation of sip_ver
  144. * Thu May 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5-0.1.20090520
  145. - PyQt-4.5-snapshot-20090520
  146. * Sun Apr 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.4-6
  147. - rebuild for phonon bindings (#497680)
  148. * Wed Mar 05 2009 Rex Dieter <rdieter@fedorproject.org> - 4.4.4-5
  149. - move designer plugins to main/runtime (#487622)
  150. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.4.4-4
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  152. * Fri Feb 13 2009 Than Ngo <than@redhat.com> - 4.4.4-3
  153. - rebuild against qt-4.5rc1
  154. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 4.4.4-2
  155. - Rebuild for Python 2.6
  156. * Mon Nov 10 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.4-1
  157. - PyQt-4.4.4
  158. * Tue Aug 26 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-1
  159. - PyQt-4.4.3
  160. * Sat Jun 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-2
  161. - PyQt4 is built without QtWebKit support (#451490)
  162. * Wed May 21 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4.2-1
  163. - PyQt-4.4.2
  164. * Wed May 14 2008 Rex Dieter <rdieter@fedoraproject.org> 4.4-1
  165. - PyQt-4.4
  166. - License: GPLv3 or GPLv2 with exceptions
  167. * Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 4.3.3-2
  168. - respin (gcc43)
  169. * Wed Dec 05 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.3-1
  170. - PyQt-4.3.3
  171. * Thu Nov 22 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-3
  172. - dbus support (#395741)
  173. * Mon Nov 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.3.1-1
  174. - PyQt-4.3.1
  175. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-8
  176. - drop ExcludeArch: ppc64 , qt4 bug is (hopefully) fixed.
  177. * Thu Oct 04 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-7
  178. - fix QtDesigner plugin install
  179. * Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-6
  180. - 64bit QtDesigner patch
  181. * Mon Aug 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-5
  182. - -devel: Requires: qt4-devel
  183. * Sun Aug 26 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-4
  184. - use %%python_sitearch
  185. - License: GPLv2
  186. * Thu Aug 02 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-3
  187. - fix python_sitelib typo (wrt chrpath call)
  188. - move %%_bindir stuff to -devel
  189. - mark %%doc examples non-executable
  190. - add shebang to %%_bindir/pyuic4
  191. * Tue Jul 17 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-2
  192. - remove rpath from QtDesigner.so
  193. - BR: qt4-devel > 4.3.0-8
  194. * Wed Apr 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.2-1
  195. - PyQt4-4.2
  196. * Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 4.1.1-2
  197. - fix build against multilib'd qt4
  198. * Mon Dec 11 2006 Rex Dieter <rexdieter[AT]usres.sf.net> 4.1.1-1
  199. - PyQt4-4.1.1
  200. - BR: sip-devel >= 4.5.1
  201. * Mon Nov 06 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.1-1
  202. - PyQt4-4.1
  203. * Wed Oct 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-4
  204. - don't own %%_datadir/sip (bug #206633)
  205. * Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-3
  206. - BR: qt4-devel < 4.2
  207. * Sat Jul 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-2
  208. - fix reference(s) to qmake(4)
  209. * Sun Jul 16 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0.1-1
  210. - PyQt-4.0.1
  211. * Mon Jun 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-1
  212. - PyQt-4.0(final)
  213. - BR: sip-devel >= 4.4.4 (see bug #199430)
  214. * Fri May 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.6.beta1
  215. - drop BR: qt4-MySQL qt4-ODBC qt4-PostgreSQL
  216. - drop usage of (undefined) %%sip_min
  217. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.5.beta1
  218. - cleanup for Extras
  219. * Fri Apr 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.4.beta1
  220. - 4.0beta1
  221. * Thu Apr 27 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.3.20060421
  222. - respin for sip-4.4.3
  223. - use sip-abi, sip-abi-min
  224. * Mon Apr 24 2006 Rex Dieter <rexdieter[AT]users.sf.net> 4.0-0.2.20060421
  225. - 20060421 snapshot
  226. * Wed Apr 19 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.0-0.1.20060417
  227. - first try, using 20060417 snapshot