tinyxml-vl.spec 2.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. %define underscore_version 2_5_3
  2. Name: tinyxml
  3. Version: 2.5.3
  4. Release: 3%{?_dist_release}
  5. Summary: A simple, small, C++ XML parser
  6. Group: System Environment/Libraries
  7. License: zlib
  8. URL: http://www.grinninglizard.com/tinyxml/
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}_%{underscore_version}.tar.gz
  10. Patch0: tinyxml-2.5.3-stl.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. %description
  13. TinyXML is a simple, small, C++ XML parser that can be easily integrating
  14. into other programs. Have you ever found yourself writing a text file parser
  15. every time you needed to save human readable data or serialize objects?
  16. TinyXML solves the text I/O file once and for all.
  17. (Or, as a friend said, ends the Just Another Text File Parser problem.)
  18. %package devel
  19. Summary: Development files for %{name}
  20. Group: Development/Libraries
  21. Requires: %{name} = %{version}-%{release}
  22. %description devel
  23. The %{name}-devel package contains libraries and header files for
  24. developing applications that use %{name}.
  25. %prep
  26. %setup -q -n %{name}
  27. %patch0 -p1 -b .stl
  28. touch -r tinyxml.h.stl tinyxml.h
  29. %build
  30. # Not really designed to be build as lib, DYI
  31. for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
  32. g++ $RPM_OPT_FLAGS -fPIC -o $i.o -c $i
  33. done
  34. g++ $RPM_OPT_FLAGS -shared -o lib%{name}.so.0.%{version} \
  35. -Wl,-soname,lib%{name}.so.0 *.cpp.o
  36. %install
  37. rm -rf $RPM_BUILD_ROOT
  38. # Not really designed to be build as lib, DYI
  39. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  40. mkdir -p $RPM_BUILD_ROOT%{_includedir}
  41. install -m 755 lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}
  42. ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
  43. ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  44. install -p -m 644 %{name}.h $RPM_BUILD_ROOT%{_includedir}
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %post -p /sbin/ldconfig
  48. %postun -p /sbin/ldconfig
  49. %files
  50. %defattr(-,root,root,-)
  51. %doc changes.txt readme.txt
  52. %{_libdir}/*.so.*
  53. %files devel
  54. %defattr(-,root,root,-)
  55. %doc docs/*
  56. %{_includedir}/*
  57. %{_libdir}/*.so
  58. %changelog
  59. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.3-3
  60. - rebuilt with new toolchain
  61. * Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-2vl5
  62. - fixed %BuildRoot
  63. - spec in UTF-8
  64. * Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-1vl5
  65. - initial build for VineSeed
  66. - import Fedora's 2.5.3-3
  67. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5.3-3
  68. - Autorebuild for GCC 4.3
  69. * Fri Dec 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-2
  70. - Various improvements from review (bz 407571)
  71. * Fri Nov 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-1
  72. - Initial Fedora Package