t1lib-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. %define name t1lib
  2. %define version 5.0.2
  3. %define release 3%{?_dist_release}
  4. Summary: Type 1 font rasterizer
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Epoch: 1
  9. Group: System Environment/Libraries
  10. License: LGPL
  11. URL: http://freshmeat.net/projects/t1lib
  12. Source: ftp://sunsite.unc.edu/pub/Linux/libs/graphics/%{name}-%{version}.tar.gz
  13. Patch0: %{name}-DESTDIR.patch
  14. Patch1: %{name}-doc.patch.bz2
  15. Patch2: %{name}-config.patch.bz2
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libICE-devel libX11-devel libXaw-devel libXpm-devel
  18. BuildRequires: texlive
  19. %description
  20. T1lib is a library for generating character and string-glyphs from
  21. Adobe Type 1 fonts under UNIX. T1lib uses most of the code of the X11
  22. rasterizer donated by IBM to the X11-project. But some disadvantages
  23. of the rasterizer being included in X11 have been eliminated.
  24. T1lib also includes a support for antialiasing.
  25. %package devel
  26. Summary: Header files for Type 1 font rasterizer
  27. Group: Development/Libraries
  28. Requires: %{name} = %{epoch}:%{version}
  29. Provides: %{name}-devel = %{version}-%{release}
  30. %description devel
  31. Header files required for compiling packages
  32. needing the t1lib.
  33. %package static-devel
  34. Summary: Static libraries for Type 1 font rasterizer
  35. Group: Development/Libraries
  36. Requires: %{name}-devel = %{epoch}:%{version}-%{release}
  37. Provides: %{name}-static-devel = %{version}-%{release}
  38. %description static-devel
  39. Static libraries required for staticaly compiling packages needing the t1lib.
  40. %package progs
  41. Summary: Programs dor manipulating Type 1 font
  42. Group: Applications/Graphics
  43. License: GPL
  44. Requires: %{name} = %{epoch}:%{version}
  45. Provides: %{name}-progs
  46. %description progs
  47. The t1lib-progs contains the programs "xglyph" and "type1afm"
  48. It also contains the "t1libconfig" script used to configure t1lib.
  49. %prep
  50. rm -rf %buildroot
  51. %setup -q
  52. %patch0 -p1
  53. %patch1 -p0
  54. %patch2 -p0
  55. %build
  56. %configure
  57. export tagname=CC
  58. perl -pi -e 's,-DGLOBAL_CONFIG_DIR="\\"/usr/share/t1lib\\"",-DGLOBAL_CONFIG_DIR="\\"/etc/t1lib\\"",;' Makefile
  59. (cd lib
  60. perl -pi -e 's,$(DESTDIR)/usr/share/t1lib,$(DESTDIR)$(datedir)t1lib,;' Makefile
  61. )
  62. make without_doc LIBTOOL=/usr/bin/libtool
  63. (cd doc
  64. make clean
  65. make pdf)
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. install -d $RPM_BUILD_ROOT%{_libdir} \
  69. $RPM_BUILD_ROOT%{_datadir} \
  70. $RPM_BUILD_ROOT%{_bindir} \
  71. $RPM_BUILD_ROOT%{_includedir}
  72. export tagname=CC
  73. %makeinstall DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
  74. #rm -rf %buildroot/%{_datadir}/t1lib/doc
  75. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
  76. mv $RPM_BUILD_ROOT%{_datadir}/t1lib/t1lib.config $RPM_BUILD_ROOT%{_sysconfdir}/t1lib
  77. %ifarch alpha
  78. (cd $RPM_BUILD_ROOT%{_libdir}
  79. ln -sf libt1.so libt1.so.0)
  80. %endif
  81. ## remove unuse files
  82. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  83. %post -n %{name} -p /sbin/ldconfig
  84. %postun -n %{name} -p /sbin/ldconfig
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files -n %{name}
  88. %defattr(-,root,root)
  89. %config(noreplace) %{_sysconfdir}/t1lib/t1lib.config
  90. %doc Changes LGPL README.t1*
  91. %attr(755,root,root) %{_libdir}/libt1*.so.*
  92. %files -n %{name}-devel
  93. %defattr(-,root,root)
  94. %doc LGPL doc/t1lib_doc.pdf
  95. %{_includedir}/*
  96. %{_libdir}/*.so
  97. %files -n %{name}-static-devel
  98. %defattr(-,root,root)
  99. %doc LGPL
  100. %{_libdir}/*.a
  101. #%{_libdir}/*.la
  102. %files -n %{name}-progs
  103. %defattr(-,root,root)
  104. %doc LICENSE README.t1python
  105. %attr(755,root,root) %{_bindir}/*
  106. %changelog
  107. * Mon Apr 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-3
  108. - rebuild with current VineSeed
  109. - use BR: texlive instead of tetex
  110. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-2vl5
  111. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  112. - spec in utf-8
  113. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.0.2-1vl5
  114. - applied new versioning policy
  115. - removed *.la
  116. - added BuildRequires: xorg-x11-devel libXpm-devel, instead of XFree86-devel xpm-devel
  117. * Sat Dec 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-0vl2
  118. - fixed spec file to build current environment
  119. - added %{epoch} related t1libs
  120. * Sat Jun 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0.2-0vl1
  121. - updated to 5.0.2
  122. - changed Group:
  123. * Sun Mar 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0.0-0vl1
  124. - new upstream release 5.0.0
  125. * Fri May 31 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.3.1-5vl0
  126. - modified for Vine
  127. * Thu May 16 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-5mdk
  128. - 9.0 lib policy: added %libname-static-devel
  129. * Wed Apr 17 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-4mdk
  130. - use %%makeinstall_std
  131. - use %%buildroot
  132. - devel package provides %%version-%%release
  133. * Sat Feb 02 2002 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.3.1-3mdk
  134. - fixed multiple "install -d" (problem with {).
  135. * Mon Jan 21 2002 Yves Duret <yduret@mandrakesoft.com> 1.3.1-2mdk
  136. - use the freshmeat url
  137. * Sun Jan 13 2002 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.3.1-1mdk
  138. - 1.3.1.
  139. - Remove the URL. There doesn't seem to be one for it.
  140. * Sun Oct 28 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 1.3-1mdk
  141. - The all new-and-shiny t1lib 1.3.
  142. * Wed Aug 15 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.2-2mdk
  143. - removed .dvi.gz doc.
  144. - removed .ps docs and unneeded .eps files. All printable doc files
  145. now replaced with only one PDF doc file.
  146. * Tue Aug 07 2001 Yves Duret <yduret@mandrakesoft.com> 1.2-1mdk
  147. - version 1.2
  148. - s{Serial}{Epoch} & s{Copyright}{License}
  149. - updated url & source
  150. - added Patch{0,1,2}
  151. - fix buildrequires
  152. - remove big, fussy and redundand pdf/ps doc (ghibo sux) :
  153. size of devel rpm divided by more than 2 !
  154. * Wed May 23 2001 Yves Duret <yduret@mandrakesoft.com> 1.1.1-2mdk
  155. - more and more macros
  156. - s{Copyright}{License}
  157. * Sat May 05 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.1.1-1mdk
  158. - updated to release 1.1.1 (bugfixes).
  159. * Tue Mar 13 2001 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.1.0-1mdk
  160. - updated to release 1.1.0.
  161. - gzip doc instead of bzip2.
  162. - removed docdir patch.
  163. * Wed Dec 27 2000 Yves Duret <yduret@mandrakesoft.com> 1.0.1-6mdk
  164. - added a obsoletes -devel tag.
  165. * Tue Dec 26 2000 Yves Duret <yduret@mandrakesoft.com> 1.0.1-5mdk
  166. - splitted into main deval and progs packages.
  167. - config file now in /etc as it should be
  168. - used bzip2 instead of gzip for doc
  169. - macros
  170. * Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.0.1-4mdk
  171. - automatically added BuildRequires
  172. * Fri Jul 28 2000 Frederic Crozat <fcrozat@mandrakesoft.com> 1.0.1-3mdk
  173. - BM + macroszification
  174. * Tue May 16 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.0.1-2mdk
  175. - Move .so from devel to package and add some links for alpha.
  176. * Sat Apr 01 2000 Giuseppe Ghibメ<ghibo@mandrakesoft.com> 1.0.1-1mdk
  177. - updated to version 1.0.1.
  178. - moved .so file to devel package.
  179. - exchanged package group between main and -devel packages.
  180. * Thu Mar 23 2000 Daouda Lo <daouda@mandrakesoft.com> 0.9.2-3mdk
  181. - fix group.
  182. * Thu Jan 13 2000 Pixel <pixel@mandrakesoft.com>
  183. - libtoolize --force.
  184. * Sat Oct 30 1999 Giuseppe Ghibメ<ghibo@linux-mandrake.com>
  185. - updated to version 0.9.2.
  186. * Thu Aug 12 1999 Giuseppe Ghibメ<ghibo@linux-mandrake.com>
  187. - added PostScript documentation.
  188. - split into main and devel package.
  189. * Sun Aug 1 1999 Richard D. Jackson <richardj@1gig.net>
  190. - first release of t1lib-0.9.1