libtiff-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library of functions for manipulating TIFF format image files.
  3. Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
  4. Name: libtiff
  5. Version: 4.2.0
  6. Release: 1%{_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke, iwamoto
  11. License: distributable
  12. URL: http://www.simplesystems.org/libtiff/
  13. Source0: http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
  14. Patch0: libtiff-am-version.patch
  15. Patch1: libtiff-make-check.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: zlib-devel libjpeg-devel
  18. %define LIBVER %(echo %{version} | cut -f-2 -d.)
  19. %ifarch x86_64
  20. Provides: libtiff.so.4()(64bit)
  21. %else
  22. Provides: libtiff.so.4
  23. %endif
  24. Obsoletes: libtiff4
  25. %description
  26. The libtiff package contains a library of functions for manipulating
  27. TIFF (Tagged Image File Format) image format files. TIFF is a widely
  28. used file format for bitmapped images. TIFF files usually end in the
  29. .tif extension and they are often quite large.
  30. The libtiff package should be installed if you need to manipulate TIFF
  31. format image files.
  32. %description -l ja
  33. libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
  34. 扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
  35. 広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
  36. 拡張子が使われ,サイズは概して大きめです.
  37. TIFF 形式の画像ファイルを扱う必要があるならば,
  38. libtiff パッケージを是非インストールして下さい.
  39. %package devel
  40. Summary: Development tools for programs which will use the libtiff library.
  41. Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
  42. Group: programming
  43. Requires: libtiff = %{version}
  44. %description devel
  45. This package contains the header files and static libraries for
  46. developing programs which will manipulate TIFF format image files
  47. using the libtiff library.
  48. If you need to develop programs which will manipulate TIFF format
  49. image files, you should install this package. You'll also need to
  50. install the libtiff package.
  51. #'
  52. %description devel -l ja
  53. このパッケージには,libtiff ライブラリを使って TIFF 形式の
  54. 画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
  55. スタティックライブラリが収められています.
  56. TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
  57. このパッケージをインストールして下さい.libtiff パッケージも同時に
  58. インストールする必要があります.
  59. ## to build compat32 for x86_64 architecture support
  60. %package -n compat32-%{name}
  61. Summary: A library of functions for manipulating TIFF format image files.
  62. Group: system
  63. Requires: %{name} = %{version}
  64. Provides: libtiff.so.4
  65. Obsoletes: compat32-libtiff4
  66. %description -n compat32-%{name}
  67. The libtiff package contains a library of functions for manipulating
  68. TIFF (Tagged Image File Format) image format files. TIFF is a widely
  69. used file format for bitmapped images. TIFF files usually end in the
  70. .tif extension and they are often quite large.
  71. The libtiff package should be installed if you need to manipulate TIFF
  72. format image files.
  73. %package -n compat32-%{name}-devel
  74. Summary: Development tools for programs which will use the libtiff library.
  75. Group: programming
  76. Requires: compat32-%{name} = %{version}
  77. Requires: %{name}-devel = %{version}
  78. %description -n compat32-%{name}-devel
  79. This package contains the header files and static libraries for
  80. developing programs which will manipulate TIFF format image files
  81. using the libtiff library.
  82. If you need to develop programs which will manipulate TIFF format
  83. image files, you should install this package. You'll also need to
  84. install the libtiff package.
  85. #'
  86. %debug_package
  87. %prep
  88. %setup -q -n tiff-%{version}
  89. %patch0 -p1
  90. %patch1 -p1
  91. # Use build system's libtool.m4, not the one in the package.
  92. rm -f libtool.m4
  93. libtoolize --force --copy
  94. aclocal -I . -I m4
  95. automake --add-missing --copy
  96. autoconf
  97. autoheader
  98. %build
  99. export CFLAGS="%{optflags} -fno-strict-aliasing"
  100. %configure \
  101. --enable-ld-version-script \
  102. --with-jpeg-lib-dir=%{_libdir} \
  103. --disable-cxx
  104. %__make %{?_smp_mflags}
  105. %__make clean
  106. %install
  107. rm -fr %{buildroot}
  108. %makeinstall
  109. ln -sf libtiff.so.5 $RPM_BUILD_ROOT%{_libdir}/libtiff.so.4
  110. rm -rf %{buildroot}/usr/share/doc/tiff-%{version}
  111. rm -f %{buildroot}%{_libdir}/libtiff*.{a,la}
  112. %clean
  113. rm -rf $RPM_BUILD_ROOT
  114. %post -p /sbin/ldconfig
  115. %postun -p /sbin/ldconfig
  116. %if %{build_compat32}
  117. %post -n compat32-%{name} -p /sbin/ldconfig
  118. %postun -n compat32-%{name} -p /sbin/ldconfig
  119. %endif
  120. %files
  121. %defattr(-,root,root)
  122. %license COPYRIGHT
  123. %doc README RELEASE-DATE VERSION
  124. %{_bindir}/*
  125. %{_libdir}/libtiff*.so.*
  126. %{_mandir}/man1/*
  127. %files devel
  128. %defattr(-,root,root)
  129. %doc TODO html ChangeLog
  130. %{_includedir}/*
  131. %{_libdir}/libtiff*.so
  132. %{_libdir}/pkgconfig/*.pc
  133. %{_mandir}/man3/*
  134. ## to build compat32 for x86_64 architecture support
  135. %if %{build_compat32}
  136. %files -n compat32-%{name}
  137. %defattr(-,root,root)
  138. %{_libdir}/libtiff.so.*
  139. %files -n compat32-%{name}-devel
  140. %defattr(-,root,root)
  141. %{_libdir}/libtiff.so
  142. %endif
  143. %changelog
  144. * Tue Dec 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.0-1
  145. - new upstream release.
  146. * Mon Jun 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1.0-1
  147. - new upstream release.
  148. - dropped Patch1001-1004: fixed in upstream.
  149. * Tue Oct 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-2
  150. - rebuilt with libjpeg.so.8.
  151. * Sun Sep 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.10-1
  152. - new upstream release.
  153. - dropped Patch1000: fixed in upstream.
  154. - imported Patch1001-1003 from rawhide.
  155. - imported Patch1004 from upstream.
  156. * Fri Dec 15 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
  157. - updated to 4.0.9.
  158. - added Patch1000 to fix CVE-2017-9935.
  159. * Sat Jun 3 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 4.0.8-1
  160. - update to 4.0.8
  161. - drop patches; upstream fixed
  162. - HylaFAX patch (Patch2)
  163. - CVE patches (Patch3..16)
  164. * Sat May 6 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  165. - imported patches from rawhide.
  166. - fixed CVE-2017-759{2,3,4,5,6,7,8,9}, CVE-2017-760{0,1,2}
  167. - fixed CVE-2016-1026{6,7,8,9}, CVE-2016-1027{0,1,2}
  168. * Sun Mar 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  169. - new upstream release.
  170. - drooped patch1-11: fixed in upstream.
  171. * Thu Dec 26 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-2
  172. - add patch1-11 from fc21 to fix security issues
  173. * Mon Nov 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.3-1
  174. - new upstream release with security fix (CVE-2012-4447)
  175. - drop *.a files from -devel packages
  176. * Thu Aug 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.2-4
  177. - new upstream release with security fixes (CVE-2012-2088, 2113)
  178. - drop patch1 (is included in new release)
  179. * Wed Jun 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-4
  180. - Obosletes: libtiff4 and compat32-libtiff4 (vl6)
  181. * Sun May 20 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-3
  182. - fix R: for compat32 package
  183. * Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-2
  184. - add libtiff.so.4 for compatibility
  185. - add pkgconfig file
  186. * Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  187. - new upstream release
  188. - add patch1 to fix CVE-2012-1173
  189. * Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
  190. - new upstream release
  191. - drop all patches (are included in new release)
  192. - remove if-endif for Vine 4.x
  193. - add Vendor/Distri tags
  194. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
  195. - add some patches from RHEL6 3.9.4-1.el6_0.3
  196. - fix for CVE-2011-0192 (Patch11)
  197. - fix for CVE-2011-1167 (Patch12)
  198. - fix for CVE-2009-5022 (Patch13)
  199. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
  200. - rebuilt with rpm-4.8.1-3
  201. * Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
  202. - new upstream release
  203. - add patch4-10 from fedora
  204. * Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
  205. - new upstream release
  206. - remove BC: freeglut-devel
  207. - add patch1,2,4,5 from fedora
  208. - drop obsolete patches
  209. * Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
  210. - change if-endif to make both i386 and compat32 packages
  211. * Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
  212. - add patch5 for fix CVE-2009-2347 (Integer Overflow)
  213. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
  214. - add patch4 for fix lzw underflow security issue
  215. - add if branch Vine4/5 in devel files section (*.la are included or not)
  216. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
  217. - removed *.la
  218. - spec in utf-8
  219. * Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
  220. - fix changelog typo (3.8.4 -> 3.8.2)
  221. - new versioning policy
  222. - add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
  223. * Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
  224. - fix libdir in libtiff.la
  225. - add BuildConflicts: freeglut-devel
  226. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
  227. - rebuilt without glut-devel
  228. * Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
  229. - add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
  230. * Fri Jun 9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
  231. - new upstream release
  232. - remove obsolete patches
  233. - add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
  234. - delete duped docs
  235. - add --disable-cxx to configure option
  236. - add *.la to devel package
  237. * Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
  238. - added compat32-* packages for x86_64 architecture support
  239. - added --with-jpeg-lib-dir=%{_libdir} to configure
  240. * Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
  241. - new upstream release
  242. - remove obsolete patches
  243. - cleanup specs
  244. * Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
  245. - rebuild for Vine3.1
  246. * Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
  247. - add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
  248. - update URL
  249. * Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
  250. - build for Vine2.6
  251. * Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
  252. - fix changelog: proper name
  253. * Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
  254. - add symlink to shared lib by running ldconfig at compile time
  255. * Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
  256. - add patch8-13 from Fedora Core
  257. --* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
  258. --- fix some integer and buffer overflows (#134853, #134848)
  259. - add patch14 from SUSE LINUX
  260. --* Wed Oct 20 2004 - meissner@suse.de
  261. --- Do not crash if we are using unsupported codecs (like OJPEG).
  262. * Wed Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
  263. - rebuild with new toolchains
  264. - to use License instead of Copyright
  265. * Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
  266. - 3.5.7-6vl1
  267. - based on 3.5.7-6 from Rawhide
  268. * Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  269. - 3.5.5-8vl1
  270. - based on 3.5.5-8 from Rawhide
  271. - added Japanese summary and description
  272. * Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
  273. - rebuild
  274. * Mon Aug 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
  275. - added a tiff-to-ps.fpi filter for printing
  276. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  277. - automatic rebuild
  278. * Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
  279. - apply Peter Skarpetis's fix for the 32-bit conversion
  280. * Mon Jul 3 2000 Nalin Dahyabhai <nalin@redhat.com>
  281. - make man pages non-executable (#12811)
  282. * Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
  283. - remove CVS repo info from data directories
  284. * Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  285. - fix build rooting
  286. - fix syntax error in configure script
  287. - move man pages to %{_mandir}
  288. * Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  289. - rebuild for an errata release
  290. * Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  291. - update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
  292. * Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  293. - fix fax2ps swapping height and width in the bounding box
  294. * Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
  295. - move man pages from devel package to the regular one
  296. - integrate Frank Warmerdam's fixed .fax handling code (keep until next release
  297. of libtiff)
  298. - fix fax2ps breakage (bug #8345)
  299. * Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
  300. - set MANDIR=man3 to make multifunction man pages friendlier
  301. * Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  302. - fix URLs
  303. * Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  304. - link shared library against libjpeg and libz
  305. * Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  306. - enable zip and jpeg codecs
  307. - change defattr in normal package to 0755
  308. - add defattr to -devel package
  309. * Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
  310. - update to 3.5.4
  311. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  312. - auto rebuild in the new build environment (release 6)
  313. * Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
  314. - build for glibc 2.1
  315. * Wed Jun 10 1998 Prospector System <bugs@redhat.com>
  316. - translations modified for de
  317. * Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
  318. - rebuilt against fixed jpeg libs (libjpeg-6b)
  319. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  320. - translations modified for de, fr, tr
  321. * Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
  322. - new version to replace the one from libgr
  323. - patched for glibc
  324. - added shlib support