perl-WWW-Mechanize-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. #
  2. # Rebuild switches:
  3. # --with localtests enable local tests
  4. %bcond_with localtests
  5. # --with livetests enable live tests
  6. %bcond_with livetests
  7. Name: perl-WWW-Mechanize
  8. Version: 1.54
  9. Release: 1%{?_dist_release}
  10. Summary: Automates web page form & link interaction
  11. Group: Development/Libraries
  12. License: GPL+ or Artistic
  13. URL: http://search.cpan.org/dist/WWW-Mechanize/
  14. Source0: http://www.cpan.org/authors/id/P/PE/PETDANCE/WWW-Mechanize-%{version}.tar.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  16. BuildArch: noarch
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. BuildRequires: perl(Test::More)
  20. BuildRequires: perl(Test::Pod), perl(Test::Pod::Coverage)
  21. BuildRequires: perl(Test::Exception)
  22. BuildRequires: perl(Test::Memory::Cycle), perl(Test::Taint), perl(Test::Warn)
  23. BuildRequires: perl(HTML::TokeParser), perl(LWP::UserAgent) >= 5.829, perl(URI::URL)
  24. BuildRequires: perl(IO::Socket::SSL)
  25. BuildRequires: perl(URI) >= 1.36
  26. BuildRequires: perl(HTTP::Server::Simple)
  27. BuildRequires: perl(HTTP::Response::Encoding) >= 0.05
  28. %description
  29. "WWW::Mechanize", or Mech for short, helps you automate interaction
  30. with a website. It supports performing a sequence of page fetches
  31. including following links and submitting forms. Each fetched page is
  32. parsed and its links and forms are extracted. A link or a form can be
  33. selected, form fields can be filled and the next page can be fetched.
  34. Mech also stores a history of the URLs you've visited, which can be
  35. queried and revisited.
  36. %prep
  37. %setup -q -n WWW-Mechanize-%{version}
  38. %build
  39. %{__perl} Makefile.PL INSTALLDIRS=vendor \
  40. %if %{with localtests}
  41. --local \
  42. %else
  43. --nolocal \
  44. %endif
  45. %if %{with livetests}
  46. --live
  47. %else
  48. --nolive
  49. %endif
  50. make %{?_smp_mflags}
  51. %install
  52. rm -rf %{buildroot}
  53. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  54. find %{buildroot} -type f -name .packlist -exec rm -f {} +
  55. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  56. %{_fixperms} %{buildroot}/*
  57. %check
  58. make test
  59. %clean
  60. rm -rf %{buildroot}
  61. %files
  62. %defattr(-,root,root,-)
  63. %doc Changes etc/www-mechanize-logo.png
  64. %{_bindir}/mech-dump
  65. %{perl_vendorlib}/WWW/
  66. %{_mandir}/man1/*.1*
  67. %{_mandir}/man3/*.3pm*
  68. %changelog
  69. * Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.54-1
  70. - initial build for Vine Linux based on fedora development
  71. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.54-3
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  73. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.54-2
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  75. * Sat Feb 21 2009 Ralf Cors辿pius <corsepiu@fedoraproject.org> - 1.54-1
  76. - Upstream update.
  77. - Add BR: perl(URI), perl(HTTP::Server::Simple),
  78. perl(HTTP::Response::Encoding).
  79. - Use %%bcond_with and %%with to process build options.
  80. * Wed May 28 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.34-1
  81. - update to 1.34
  82. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.32-2
  83. - rebuild for new perl
  84. * Fri Dec 07 2007 Chris Weyl <cweyl@alumni.drew.edu> - 1.32-1
  85. - update to 1.32
  86. * Thu Jun 7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-2
  87. - New rebuild option: "--with livetests".
  88. * Thu Jun 7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
  89. - Update to 1.30.
  90. - The Makefile.PL --mech-dump option is now deprecated.
  91. * Thu Jun 7 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
  92. - Update to 1.24.
  93. * Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-2
  94. - New BR: perl(IO::Socket::SSL).
  95. * Sun Mar 18 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
  96. - Update to 1.22.
  97. * Tue Sep 5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
  98. - Update to 1.20.
  99. - Live tests have been dropped.
  100. * Tue Feb 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-2
  101. - Re-enable test suite but without local and live tests.
  102. One local test fails in mock (see #165650 comment 4).
  103. - New rebuild option: "--with localtests".
  104. * Thu Feb 2 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
  105. - Update to 1.18.
  106. * Thu Nov 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
  107. - Update to 1.16.
  108. * Wed Aug 31 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-2
  109. - Added Test::LongString to the live tests build requirements.
  110. * Wed Aug 31 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.14-1
  111. - Update to 1.14.
  112. * Fri Aug 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-4
  113. - Added Test::Pod::Coverage to the BR list in order to improve test coverage.
  114. - Disabled test suite as it fails in mock (see #165650 comment 4).
  115. * Thu Aug 25 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-3
  116. - Conditional rebuild switch to enable live tests (RFE in #165650).
  117. * Fri Jul 1 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-2
  118. - Dist tag.
  119. * Sat Feb 26 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.12-0.fdr.1
  120. - Update to 1.12.
  121. * Mon Feb 14 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.10-0.fdr.1
  122. - Update to 1.10.
  123. * Sat Dec 25 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.08-0.fdr.1
  124. - Update to 1.08.
  125. * Sun Jul 04 2004 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0:1.02-0.fdr.1
  126. - First build.