libsolv-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420
  1. %{!?ruby_vendorarch: %global ruby_vendorarch %(ruby -r rbconfig -e "puts RbConfig::CONFIG['vendorarchdir'].nil? ? RbConfig::CONFIG['sitearchdir'] : RbConfig::CONFIG['vendorarchdir']")}
  2. %define _unpackaged_files_terminate_build 1
  3. %define filter_provides_in(P) %{expand: \
  4. %global __filter_prov_cmd %{?__filter_prov_cmd} %{__grep} -v %{-P} '%*' | \
  5. }
  6. %define filter_setup %{expand: \
  7. %global _use_internal_dependency_generator 0 \
  8. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u \
  9. %global __find_provides /bin/sh -c "%{?__filter_prov_cmd} %{__deploop P} %{?__filter_from_prov}" \
  10. %global __find_requires /bin/sh -c "%{?__filter_req_cmd} %{__deploop R} %{?__filter_from_req}" \
  11. }
  12. %filter_provides_in %{perl_vendorarch}/.*\.so$
  13. %filter_provides_in %{python3_sitearch}/.*\.so$
  14. %global _cmake_opts \\\
  15. -DFEDORA=1 \\\
  16. -DCMAKE_BUILD_TYPE=RelWithDebInfo \\\
  17. -DENABLE_PERL=1 \\\
  18. -DENABLE_PYTHON=1 \\\
  19. -DENABLE_RUBY=1 \\\
  20. -DUSE_VENDORDIRS=1 \\\
  21. -DENABLE_DEBIAN=1 \\\
  22. -DENABLE_ARCHREPO=1 \\\
  23. -DENABLE_SUSEREPO=1 \\\
  24. -DENABLE_HELIXREPO=1 \\\
  25. -DENABLE_LZMA_COMPRESSION=1 \\\
  26. -DENABLE_ZSTD_COMPRESSION=1 \\\
  27. -DMULTI_SEMANTICS=1 \\\
  28. -DENABLE_COMPLEX_DEPS=1 \\\
  29. %{nil}
  30. %filter_provides_in %{ruby_vendorarch}/.*\.so$
  31. %filter_setup
  32. Name: libsolv
  33. Summary: Package dependency solver
  34. Version: 0.7.25
  35. Release: 1%{?_dist_release}
  36. Group: system
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. License: BSD
  40. URL: https://github.com/openSUSE/libsolv
  41. Source: https://github.com/openSUSE/libsolv/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  42. #Patch0: 0001-ruby-make-compatible-with-ruby-2.2.patch
  43. BuildRequires: git git-devel
  44. BuildRequires: cmake libdb-devel expat-devel rpm-devel zlib-devel
  45. BuildRequires: swig
  46. BuildRequires: perl ruby ruby-devel
  47. BuildRequires: python3-devel
  48. BuildRequires: python3-setuptools
  49. BuildRequires: python3-rpm-macros
  50. BuildRequires: xz-devel
  51. BuildRequires: libzstd-devel
  52. %description
  53. A free package dependency solver using a satisfiability algorithm. The
  54. library is based on two major, but independent, blocks:
  55. - Using a dictionary approach to store and retrieve package
  56. and dependency information.
  57. - Using satisfiability, a well known and researched topic, for
  58. resolving package dependencies.
  59. %package devel
  60. Summary: A new approach to package dependency solving
  61. Group: programming
  62. Requires: libsolv-tools%{?_isa} = %{version}-%{release}
  63. Requires: libsolv%{?_isa} = %{version}-%{release}
  64. Requires: rpm-devel%{?_isa}
  65. Requires: cmake
  66. %description devel
  67. Development files for libsolv,
  68. %package tools
  69. Summary: A new approach to package dependency solving
  70. Group: programming
  71. Requires: gzip bzip2 coreutils
  72. Requires: libsolv%{?_isa} = %{version}-%{release}
  73. %description tools
  74. Package dependency solver tools.
  75. %package demo
  76. Summary: Applications demoing the libsolv library
  77. Group: programming
  78. Requires: curl gnupg
  79. %description demo
  80. Applications demoing the libsolv library.
  81. %package -n ruby-solv
  82. Summary: Ruby bindings for the libsolv library
  83. Group: programming
  84. Requires: libsolv%{?_isa} = %{version}-%{release}
  85. %description -n ruby-solv
  86. Ruby bindings for sat solver.
  87. %package -n python3-solv
  88. Summary: Python 3 bindings for the libsolv library
  89. Group: programming
  90. Requires: python3
  91. Requires: libsolv%{?_isa} = %{version}-%{release}
  92. %{?python_provide:%python_provide python3-solv}
  93. %description -n python3-solv
  94. Python 3 bindings for sat solver.
  95. %package -n perl-solv
  96. Summary: Perl bindings for the libsolv library
  97. Group: programming
  98. Requires: perl
  99. Requires: libsolv%{?_isa} = %{version}-%{release}
  100. %description -n perl-solv
  101. Perl bindings for sat solver.
  102. %debug_package
  103. %prep
  104. %autosetup -S git
  105. %build
  106. %cmake %_cmake_opts \
  107. -DPYTHON_EXECUTABLE=%{python3} \
  108. -DPythonLibs_FIND_VERSION=3 -DPythonLibs_FIND_VERSION_MAJOR=3
  109. %cmake_build
  110. %install
  111. %cmake_install
  112. %check
  113. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}
  114. %ctest
  115. %files
  116. %license LICENSE*
  117. %doc README BUGS
  118. %_libdir/libsolv.so.*
  119. %_libdir/libsolvext.so.*
  120. %files tools
  121. %_bindir/archpkgs2solv
  122. %_bindir/archrepo2solv
  123. %_bindir/deb2solv
  124. %_bindir/deltainfoxml2solv
  125. %_bindir/dumpsolv
  126. %_bindir/helix2solv
  127. %_bindir/installcheck
  128. %_bindir/mergesolv
  129. %_bindir/repo2solv
  130. %_bindir/repomdxml2solv
  131. %_bindir/rpmdb2solv
  132. %_bindir/rpmmd2solv
  133. %_bindir/rpms2solv
  134. %_bindir/susetags2solv
  135. %_bindir/testsolv
  136. %_bindir/updateinfoxml2solv
  137. %files devel
  138. %doc examples/solv/
  139. %_libdir/libsolv.so
  140. %_libdir/libsolvext.so
  141. %_includedir/solv
  142. %_datadir/cmake/Modules/FindLibSolv.cmake
  143. %{_mandir}/man?/*
  144. %{_libdir}/pkgconfig/%{name}.pc
  145. %{_libdir}/pkgconfig/%{name}ext.pc
  146. %files demo
  147. %_bindir/solv
  148. %files -n perl-solv
  149. %doc examples/p5solv
  150. %{perl_vendorarch}/*
  151. %files -n ruby-solv
  152. %doc examples/rbsolv
  153. %{ruby_vendorarch}/*
  154. %files -n python3-solv
  155. %doc examples/pysolv
  156. %{python3_sitearch}/*
  157. %changelog
  158. * Thu Oct 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.25-1
  159. - new upstream release.
  160. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.22-1
  161. - new upstream release.
  162. * Tue Oct 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.20-1
  163. - new upstream release.
  164. * Thu Sep 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.19-1
  165. - new upstream release.
  166. - dropped ldconfig scriptlets.
  167. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.17-2
  168. - rebuilt with rpm-4.16.
  169. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.17-1
  170. - new upstream release.
  171. - dropped python2 support.
  172. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.11-1
  173. - new upstream release.
  174. * Tue Sep 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.7.6-1
  175. - new upstream release.
  176. * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.35-1
  177. - new upstream release.
  178. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.30-1
  179. - new upstream release.
  180. * Sun Jul 17 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.22-1
  181. - new upstream release.
  182. * Sun May 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.20-1
  183. - new upstream release.
  184. * Sun Nov 22 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.6.14-4
  185. - initial build for Vine Linux.
  186. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.14-3
  187. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  188. * Wed Oct 14 2015 Michal Luscon <mluscon@redhat.com> - 0.6.14-2
  189. - Backport patches from upstream
  190. * Mon Oct 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.6.14-1
  191. - Update to 0.6.14
  192. - Backport patches from upstream
  193. * Thu Sep 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.6.12-1
  194. - Update to 0.6.12
  195. * Wed Aug 05 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.11-3
  196. - added compile flag to support rich dependencies
  197. - new version adding MIPS support
  198. - Distribute testsolv in -tools subpackage (Igor Gnatenko)
  199. - Enable python3 bindings for fedora (Igor Gnatenko)
  200. * Tue Aug 04 2015 Adam Williamson <awilliam@redhat.com> - 0.6.11-2
  201. - make bindings require the exact matching version of the lib (#1243737)
  202. * Mon Jun 22 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.11-1
  203. - new version fixing segfault
  204. - RbConfig fixed in the upstream (1928f1a), libsolv-ruby22-rbconfig.patch erased
  205. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.10-2
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  207. * Wed Mar 25 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.10-1
  208. - new version fixing segfault
  209. * Fri Mar 6 2015 Jan Silhan <jsilhan@redhat.com> - 0.6.8-3
  210. - Rebuilt with new provides selection feature
  211. * Mon Jan 19 2015 Vít Ondruch <vondruch@redhat.com> - 0.6.8-2
  212. - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.2
  213. * Fri Jan 16 2015 Richard Hughes <richard@hughsie.com> - 0.6.8-2
  214. - Update to latest upstream release to fix a crash in PackageKit.
  215. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.4-3
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  217. * Mon Aug 11 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.4-2
  218. - Rebase to upstream 12af31a
  219. * Mon Jul 28 2014 Aleš Kozumplík <akozumpl@redhat.com> - 0.6.4-1
  220. - Rebase to upstream 5bd9589
  221. * Mon Jul 14 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.4-0.git2a5c1c4
  222. - Rebase to upstream 2a5c1c4
  223. - Filename selector can start with a star
  224. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2.git6d968f1
  225. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  226. * Tue May 27 2014 Aleš Kozumplík <ales@redhat.com> - 0.6.1-1.git6d968f1
  227. - Rebase to upstream 6d968f1
  228. - Fix RhBug:1049209
  229. * Fri Apr 25 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.1-0.gitf78f5de
  230. - Rebase to 0.6.0, upstream commit f78f5de.
  231. * Thu Apr 24 2014 Vít Ondruch <vondruch@redhat.com> - 0.6.0-0.git05baf54.1
  232. - Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.1
  233. * Wed Apr 9 2014 Jan Silhan <jsilhan@redhat.com> - 0.6.0-0.git05baf54
  234. - Rebase to 0.6.0, upstream commit 05baf54.
  235. * Mon Dec 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.1-1.gitbcedc98
  236. - Rebase upstream bcedc98
  237. - Fix RhBug:1051917.
  238. * Mon Dec 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.1-0.gita8e47f1
  239. - Rebase to 0.4.1, upstream commit a8e47f1.
  240. * Fri Nov 22 2013 Zdenek Pavlas <zpavlas@redhat.com> - 0.4.0-2.git4442b7f
  241. - Rebase to 0.4.0, upstream commit 4442b7f.
  242. - support DELTA_LOCATION_BASE for completeness
  243. * Tue Oct 29 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.4.0-1.gitd49d319
  244. - Rebase to 0.4.0, upstream commit d49d319.
  245. * Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 0.3.0-9.gita59d11d
  246. - Perl 5.18 rebuild
  247. * Wed Jul 31 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-8.gita59d11d
  248. - Rebase to upstream a59d11d.
  249. * Fri Jul 19 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-7.git228d412
  250. - Add build flags, including Deb, Arch, LZMA and MULTI_SEMANTICS. (RhBug:985905)
  251. * Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 0.3.0-6.git228d412
  252. - Perl 5.18 rebuild
  253. * Mon Jun 24 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-5.git228d412
  254. - Rebase to upstream 228d412.
  255. - Fixes hawkey github issue https://github.com/akozumpl/hawkey/issues/13
  256. * Thu Jun 20 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-4.git209e9cb
  257. - Rebase to upstream 209e9cb.
  258. - Package the new man pages.
  259. * Thu May 16 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-3.git7399ad1
  260. - Run 'make test' with libsolv build.
  261. * Mon Apr 8 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-2.git7399ad1
  262. - Rebase to upstream 7399ad1.
  263. - Fixes RhBug:905209
  264. * Mon Apr 8 2013 Aleš Kozumplík <akozumpl@redhat.com> - 0.3.0-1.gite372b78
  265. - Rebase to upstream e372b78.
  266. - Fixes RhBug:e372b78
  267. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-2.gitf663ca2
  268. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  269. * Thu Aug 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-17.git6c9d3eb
  270. - Rebase to upstream 6c9d3eb.
  271. - Drop the solv.i stdbool.h fix integrated upstream.
  272. - Dropped the job reasons fix.
  273. * Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-16.git1617994
  274. - Fix build problems with Perl bindings.
  275. * Mon Jul 23 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-15.git1617994
  276. - Rebuilt after a failed mass rebuild.
  277. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.0-14.git1617994
  278. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  279. * Mon Jul 16 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-13.git1617994%{?dist}
  280. - preliminary fix for JOB resons in solver_describe_decision().
  281. * Sun Jul 1 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-12.git1617994%{?dist}
  282. - Rebase to upstream 1617994.
  283. - Support for RPM_ADD_WITH_HDRID.
  284. * Thu Jun 7 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-11.gitd39a42b%{?dist}
  285. - Rebase to upstream d39a42b.
  286. - Fix the epochs.
  287. - Move the ruby modules into vendorarch dir, where they are expected.
  288. * Thu May 17 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-9.git8cf7650%{?dist}
  289. - Rebase to upstream 8cf7650.
  290. - ruby bindings: fix USE_VENDORDIRS for Fedora.
  291. * Thu Apr 12 2012 Aleš Kozumplik <akozumpl@redhat.com> - 0.0.0-7.gitaf1465a2%{?dist}
  292. - Rebase to the upstream.
  293. - Make repo_add_solv() work without stub repodata.
  294. * Thu Apr 5 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-6.git80afaf7%{?dist}
  295. - Rebuild for the new libdb package.
  296. * Mon Apr 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-5.git80afaf7%{?dist}
  297. - Rebuild for the new rpm package.
  298. * Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-4.git80afaf7%{?dist}
  299. - New upstream version, fix the .rpm release number.
  300. * Wed Mar 21 2012 Aleš Kozumplík <akozumpl@redhat.com> - 0.0.0-3.git80afaf7%{?dist}
  301. - New upstream version.
  302. * Tue Feb 7 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-2.git857fe28%{?dist}
  303. - Adapted to Ruby 1.9.3 (workaround for broken CMake in Fedora and
  304. ruby template correction in bindings)
  305. * Thu Feb 2 2012 Karel Klíč <kklic@redhat.com> - 0.0.0-1.git857fe28
  306. - Initial packaging
  307. - Based on Jindra Novy's spec file
  308. - Based on upstream spec file