libboost-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457
  1. %define major 1
  2. %define minor 45
  3. %define teeny 0
  4. %define tarname boost
  5. %define lnkver %{major}_%{minor}
  6. %define pkgver %{major}_%{minor}_%{teeny}
  7. Summary: Portable C++ source libraries
  8. Summary(ja): ポータブルな C++ ソースライブラリ
  9. Name: libboost
  10. Version: %{major}.%{minor}.%{teeny}
  11. Release: 1%{?_dist_release}
  12. Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{pkgver}.tar.bz2
  13. Source1: user-config.jam
  14. License: distributable
  15. Group: System Environment/Libraries
  16. URL: http://www.boost.org/
  17. BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
  18. BuildRequires: libaio-devel lam
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
  23. Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
  24. Obsoletes: %{name}-python-devel %{name}-regex-devel
  25. Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
  26. Obsoletes: %{name}-thread-devel %{name}-wave-devel
  27. %description
  28. Boost provides free peer-reviewed portable C++ source libraries. The emphasis
  29. is on libraries which work well with the C++ Standard Library. The libraries
  30. are intended to be widely useful, and are in regular use by thousands of
  31. programmers across a broad spectrum of applications.
  32. A further goal is to establish "existing practice" and provide reference
  33. implementations so that Boost libraries are suitable for eventual
  34. standardization. Ten Boost libraries will be included in the C++ Standards
  35. Committee's upcoming C++ Standard Library Technical Report as a step toward
  36. becoming part of a future C++ Standard.
  37. %description -l ja
  38. Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
  39. 準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
  40. ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
  41. さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
  42. を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
  43. として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
  44. 含まれる予定です。
  45. %package devel
  46. Summary: Header files and libraries for developing apps which will use %{name}
  47. Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
  48. Group: Development/Libraries
  49. Requires: %{name} = %{version}-%{release}
  50. %description devel
  51. The %{name}-devel package contains the header files and libraries needed
  52. to develop programs that use the Boost library.
  53. %description devel -l ja
  54. %{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
  55. ヘッダファイルやライブラリを含んでいます。
  56. %package doc
  57. Summary: Documents of %{name}
  58. Summary(ja): %{name}のドキュメント
  59. Group: Applications/Documentation
  60. Requires: %{name} = %{version}-%{release}
  61. %description doc
  62. The %{name}-doc package contains the documents about the boost library.
  63. %description doc -l ja
  64. %{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
  65. %package date-time
  66. Summary: Set of data-time libralies in %{name}
  67. Group: System Environment/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. %description date-time
  70. Set of data-time libralies in %{name}
  71. %package filesystem
  72. Summary: Set of filesystem operation libralies in %{name}
  73. Group: System Environment/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. %description filesystem
  76. Set of filesystem operation libralies in %{name}
  77. %package graph
  78. Summary: Set of Graphviz libralies in %{name}
  79. Group: System Environment/Libraries
  80. Requires: %{name} = %{version}-%{release}
  81. %description graph
  82. Set of Graphviz libralies in %{name}
  83. %package iostreams
  84. Summary: Set of streams and i/o filters libralies in %{name}
  85. Group: System Environment/Libraries
  86. Requires: %{name} = %{version}-%{release}
  87. %description iostreams
  88. Set of streams and i/o filters libralies in %{name}
  89. %package math
  90. Summary: Set of math libralies in %{name}
  91. Group: System Environment/Libraries
  92. Requires: %{name} = %{version}-%{release}
  93. %description math
  94. Set of math libralies in %{name}
  95. %package program-options
  96. Summary: Set of program options libralies in %{name}
  97. Group: System Environment/Libraries
  98. Requires: %{name} = %{version}-%{release}
  99. %description program-options
  100. Set of program options libralies in %{name}
  101. %package python
  102. Summary: Set of Python libralies in %{name}
  103. Group: System Environment/Libraries
  104. Requires: %{name} = %{version}-%{release}
  105. %description python
  106. Set of Python libralies in %{name}
  107. %package random
  108. Summary: Set of random number generation libralies in %{name}
  109. Group: System Environment/Libraries
  110. Requires: %{name} = %{version}-%{release}
  111. %description random
  112. Set of random number generation libralies in %{name}
  113. %package regex
  114. Summary: Set of regular expression libralies in %{name}
  115. Group: System Environment/Libraries
  116. Requires: %{name} = %{version}-%{release}
  117. %description regex
  118. Set of regular expression libralies in %{name}
  119. %package serialization
  120. Summary: Set of serialization libralies in %{name}
  121. Group: System Environment/Libraries
  122. Requires: %{name} = %{version}-%{release}
  123. %description serialization
  124. Set of serialization libralies in %{name}
  125. %package signals
  126. Summary: Set of signals and slots libralies in %{name}
  127. Group: System Environment/Libraries
  128. Requires: %{name} = %{version}-%{release}
  129. %description signals
  130. Set of signals and slots libralies in %{name}
  131. %package system
  132. Summary: Operating system support
  133. Group: System Environment/Libraries
  134. Requires: %{name} = %{version}-%{release}
  135. %description system
  136. Operating system support, including the diagnostics support
  137. that will be part of the C++0x standard library
  138. %package test
  139. Summary: Set of libraries for writing and executing tests in %{name}
  140. Group: System Environment/Libraries
  141. Requires: %{name} = %{version}-%{release}
  142. %description test
  143. Set of libraries for writing and executing tests in %{name}
  144. %package thread
  145. Summary: Set of multi-thread libraries in %{name}
  146. Group: System Environment/Libraries
  147. Requires: %{name} = %{version}-%{release}
  148. %description thread
  149. Set of multi-thread libraries in %{name}
  150. %package wave
  151. Summary: Set of wave libraries in %{name}
  152. Group: System Environment/Libraries
  153. Requires: %{name} = %{version}-%{release}
  154. %description wave
  155. Set of wave libraries in %{name}
  156. %prep
  157. %setup -q -n %{tarname}_%{pkgver}
  158. cp %SOURCE1 user-config.jam
  159. %build
  160. ## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
  161. ## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
  162. ./bootstrap.sh \
  163. --prefix=%{_prefix} \
  164. --libdir=%{_libdir} \
  165. --includedir=%{_includedir} \
  166. --with-icu=%{_prefix} \
  167. --with-python-version=%{pyver}
  168. ./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
  169. %install
  170. rm -rf $RPM_BUILD_ROOT
  171. ## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
  172. ./bjam \
  173. --prefix=${RPM_BUILD_ROOT}%{_prefix} \
  174. --libdir=${RPM_BUILD_ROOT}%{_libdir} \
  175. --user-config=./user-config.jam \
  176. link=shared \
  177. install
  178. ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
  179. # remove unuse files
  180. rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
  181. # unnead for libboost-1.42
  182. ## pushd $RPM_BUILD_ROOT/%{_libdir}
  183. ## for i in libboost_*-mt.so
  184. ## do
  185. ## ln -sf $i $(echo $i | cut -f1 -d-).so
  186. ## done
  187. ## popd
  188. ## %post devel
  189. ## if [ $1 = 2 ]; then
  190. ## rm -rf %{_includedir}/%{tarname}
  191. ## fi
  192. ## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
  193. ##
  194. ## %postun devel
  195. ## if [ $1 = 0 ]; then
  196. ## rm -rf %{_includedir}/%{tarname}
  197. ## fi
  198. %post date-time -p /sbin/ldconfig
  199. %post filesystem -p /sbin/ldconfig
  200. %post graph -p /sbin/ldconfig
  201. %post iostreams -p /sbin/ldconfig
  202. %post math -p /sbin/ldconfig
  203. %post program-options -p /sbin/ldconfig
  204. %post python -p /sbin/ldconfig
  205. %post regex -p /sbin/ldconfig
  206. %post serialization -p /sbin/ldconfig
  207. %post signals -p /sbin/ldconfig
  208. %post system -p /sbin/ldconfig
  209. %post test -p /sbin/ldconfig
  210. %post thread -p /sbin/ldconfig
  211. %post wave -p /sbin/ldconfig
  212. %postun date-time -p /sbin/ldconfig
  213. %postun filesystem -p /sbin/ldconfig
  214. %postun graph -p /sbin/ldconfig
  215. %postun iostreams -p /sbin/ldconfig
  216. %postun math -p /sbin/ldconfig
  217. %postun program-options -p /sbin/ldconfig
  218. %postun python -p /sbin/ldconfig
  219. %postun regex -p /sbin/ldconfig
  220. %postun serialization -p /sbin/ldconfig
  221. %postun signals -p /sbin/ldconfig
  222. %postun system -p /sbin/ldconfig
  223. %postun test -p /sbin/ldconfig
  224. %postun thread -p /sbin/ldconfig
  225. %postun wave -p /sbin/ldconfig
  226. %clean
  227. rm -rf $RPM_BUILD_ROOT
  228. %files
  229. %defattr(-,root,root)
  230. %doc LICENSE_1_0.txt
  231. %files devel
  232. %defattr(-,root,root)
  233. %{_includedir}/boost/
  234. %{_includedir}/boost-%{lnkver}/
  235. %files doc
  236. %doc index.htm index.html boost.css boost.png rst.css doc libs more
  237. %files date-time
  238. %{_libdir}/%{name}_date_time*.so*
  239. %files filesystem
  240. %{_libdir}/%{name}_filesystem*.so*
  241. %files graph
  242. %{_libdir}/%{name}_graph*.so*
  243. %{_libdir}/%{name}_mpi*.so*
  244. %{_libdir}/mpi*.so*
  245. %files iostreams
  246. %{_libdir}/%{name}_iostreams*.so*
  247. %files math
  248. %{_libdir}/%{name}_math_*.so*
  249. %files program-options
  250. %{_libdir}/%{name}_program_options*.so*
  251. %files python
  252. %{_libdir}/%{name}_python*.so*
  253. %files random
  254. %{_libdir}/%{name}_random*.so*
  255. %files regex
  256. %{_libdir}/%{name}_regex*.so*
  257. %files serialization
  258. %{_libdir}/%{name}_serialization*.so*
  259. %{_libdir}/%{name}_wserialization*.so*
  260. %files signals
  261. %{_libdir}/%{name}_signals*.so*
  262. %files system
  263. %{_libdir}/%{name}_system*.so*
  264. %files test
  265. %{_libdir}/%{name}_prg_exec_monitor*.so*
  266. %{_libdir}/%{name}_unit_test_framework*.so*
  267. %files thread
  268. %{_libdir}/%{name}_thread*.so*
  269. %files wave
  270. %{_libdir}/%{name}_wave*.so*
  271. %changelog
  272. * Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.45.0-1
  273. - updated to boost_1_45_0
  274. - added random sub-package
  275. * Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
  276. - rebuilt again on ppc
  277. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
  278. - rebuilt with libicu-4.4
  279. * Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
  280. - added "-licui18n" to bjam
  281. - added BR: lam
  282. * Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
  283. - updated to boost_1_42_0
  284. - rebuilt with new toolchain and python-2.6
  285. - added user-config.jam to make libboost_mpi
  286. - added BR: libaio-devel
  287. - added %%{post,postun} -p /sbin/ldconfig
  288. - dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
  289. - dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
  290. - dropt %%{post,postun} devel section
  291. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
  292. - rebuilt with libicu-4.0.1
  293. - changed Group to System Environment/Libraries (except devel package)
  294. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
  295. - new upstream release
  296. - add -math subpackage
  297. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
  298. - build with python-2.5
  299. - add libboost_XXXX.so symlinks
  300. * Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
  301. - upstream release
  302. - applied new versioning policy
  303. - add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
  304. - add new package libboost-system
  305. - Obsolete: *-devel packages
  306. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
  307. - rebuilt with libicu-3.6
  308. - changed doc Group to Applications/Documentation
  309. * Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
  310. - upstream release
  311. * Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
  312. - add --libdir=%%{_libdir} to cope with x86_64 environment
  313. * Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
  314. - upstream release
  315. - use Easy Build and Install process with ./configure
  316. - add BuildRequires: libicu-devel
  317. - remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
  318. - add new packages: libboost-graph, libboost-graph-devel, libboost-wave
  319. - add files to doc package
  320. * Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
  321. - rebuilt with new toolchain
  322. * Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
  323. - upstream release
  324. * Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
  325. - fixed typo in Groups:
  326. - devel packages also moved to Development/Libraries group
  327. * Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
  328. - spec modified to avoid errors on non-ix86 archtecture
  329. (previously the path linuxx86 was explicitly used)
  330. * Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
  331. - initial release for Vine Linux
  332. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
  333. - link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
  334. * Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
  335. - change package name from boost to libboost
  336. - separated into sub-packages
  337. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
  338. - upstream release
  339. - add BuildRequires: bzip2-devel zlib-devel
  340. * Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
  341. - added so.* file
  342. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
  343. - moved %post, %postun script to -devel package
  344. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
  345. - moved doc/html to -devel package
  346. - make a symbolic link on %{_includedir}/boost
  347. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
  348. - fixed character code to euc-jp
  349. * Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
  350. - add %doc files
  351. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
  352. - remove Requires
  353. - split -devel package
  354. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
  355. - initial build for Vine Linux