123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453 |
- %bcond_with systemd
- %define origname procps-ng
- Summary: System and process monitoring utilities.
- Summary(ja): システムやプロセスのモニタリングユーティリティ
- Name: procps
- Version: 3.3.16
- Release: 1%{?_dist_release}%{?with_systemd:.systemd}
- Group: Applications/System
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: daisuke
- License: GPL
- Url: https://gitlab.com/procps-ng/procps
- Source: https://downloads.sourceforge.net/project/procps-ng/Production/%{origname}-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- Requires(post): /sbin/ldconfig, /bin/rm
- Requires(postun): /sbin/ldconfig
- Obsoletes: procps-X11, pgrep
- Source10: procps-ng-3.3.10-ja.po
- BuildRequires: ncurses-devel
- %if %{with systemd}
- BuildRequires: systemd-devel
- %else
- BuildRequires: elogind-devel
- %endif
- %description
- The procps package contains a set of system utilities that provide
- system information. Procps includes ps, free, skill, snice, tload,
- top, uptime, vmstat, w, and watch. The ps command displays a snapshot
- of running processes. The top command provides a repetitive update of
- the statuses of running processes. The free command displays the
- amounts of free and used memory on your system. The skill command
- sends a terminate command (or another specified signal) to a specified
- set of processes. The snice command is used to change the scheduling
- priority of specified processes. The tload command prints a graph of
- the current system load average to a specified tty. The uptime command
- displays the current time, how long the system has been running, how
- many users are logged on, and system load averages for the past one,
- five, and fifteen minutes. The w command displays a list of the users
- who are currently logged on and what they are running. The watch
- program watches a running program. The vmstat command displays virtual
- memory statistics about processes, memory, paging, block I/O, traps,
- and CPU activity.
- %description -l ja
- システムの状態を知るためのユーティリティ集です. 実行中のプロセス, 使用
- 可能なメモリ容量, 現在ログインしているユーザの情報等を得ることができます.
- %package devel
- Summary: System and process monitoring utilities
- Summary(ja): procpsを利用した開発に必要なファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- System and process monitoring utilities development headers
- %description devel -l ja
- このパッケージにはprocpsを利用した開発に必要なヘッダ・ライブラリファイル
- が収録されています。
- %prep
- %setup -q -n %{origname}-%{version}
- cp -f %{SOURCE10} po/ja.po
- %build
- autoreconf --verbose --force --install
- ./configure --prefix=/ \
- --bindir=%{_bindir} \
- --sbindir=%{_syssbindir} \
- --libdir=%{_libdir} \
- --datadir=%{_datadir} \
- --localedir=%{_datadir}/locale \
- --mandir=%{_mandir} \
- --includedir=%{_includedir} \
- --sysconfdir=%{_sysconfdir} \
- --docdir=/unwanted \
- --disable-static \
- --disable-w-from \
- --disable-kill \
- --enable-watch8bit \
- --enable-skill \
- --enable-sigwinch \
- --disable-libselinux \
- %if %{with systemd}
- --with-systemd
- %else
- --without-systemd \
- --with-elogind
- %endif
- make CFLAGS="%{optflags}"
- sed -i -e 's|/procps-ng-.*-dirty/|/|' po/Makefile
- sed -i -e 's|^procps-ng-.*-dirty/||' po/POTFILES.in
- make -C po update-po
- make -C po ja.gmo
- %install
- make DESTDIR=%{buildroot} install
- make DESTDIR=%{buildroot} -C po install
- mkdir -p %{buildroot}%{_sysconfdir}/sysctl.d
- mkdir -p %{buildroot}%{_sysbindir}
- mv %{buildroot}%{_bindir}/ps %{buildroot}%{_sysbindir}/
- ln -sf %{_sysbindir}/ps %{buildroot}%{_bindir}/ps
- rm -f %{buildroot}/%{_libdir}/libprocps.la
- rm -rf %{buildroot}/unwanted
- rm -f %{buildroot}%{_bindir}/pidof
- %find_lang procps-ng
- %clean
- rm -rf %{buildroot}
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files -f procps-ng.lang
- %defattr(-,root,root,-)
- %license COPYING COPYING.LIB
- %doc AUTHORS NEWS README*
- %{_libdir}/libprocps.so.*
- %{_bindir}/*
- %{_sysbindir}/*
- %{_syssbindir}/*
- %{_sysconfdir}/sysctl.d
- %{_mandir}/man1/*
- %{_mandir}/man3/*
- %{_mandir}/man8/*
- %{_mandir}/man5/*
- %files devel
- %defattr(-,root,root,-)
- %doc COPYING COPYING.LIB
- %{_libdir}/libprocps.so
- %{_libdir}/pkgconfig/libprocps.pc
- %{_includedir}/proc
- %changelog
- * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.16-1
- - new upstream release.
- - added systemd support (disabled as default).
- * Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.15-1
- - new upstream release.
- - enabled elogind.
- - added japanese summary.
- * Sun Jun 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-2
- - fixed Source10.
- * Sat Jun 20 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.3.10-1
- - new upstream release.
- - updated Source10 and Patch10.
- * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3.9-1
- - update to forked version of procps 3.3.9
- - add minimum ja.po
- * Sat Sep 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.8-1
- - update to 3.2.8
- - add patch30 to fix top highlight bug
- (thanks to <BTS:916>)
- * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-2
- - spec in utf-8
- * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.7-1
- - new upstream release
- * Wed Sep 20 2006 IWAI, Masaharu <iwai@alib.jp> 3.2.6-0vl3
- - [BTS:205] update ja.po ( in Patch20 )
- * Tue Feb 14 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl2
- - add Obsoletes: pgrep
- * Sun Feb 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 3.2.6-0vl1
- - upstream release
- - update Patch20
- - fix encode of spec file (SJIS -> EUC-JP)
- - add pwdx command (new from 3.2.4)
- * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl3
- - update gettext patch
- * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl2
- - add gettext patch (Patch20)
- still needs more work ( only for "free" and "uptime" )
- * Sun Feb 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.5-0vl1
- - new upstream release
- * Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2.0-1vl1
- - modified for Vine
- - add obsoletes -X11 package
- * Tue Feb 24 2004 Dan Walsh <dwalsh@redhat.com> 3.2.0-1
- - New version from upstream
- * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Thu Jan 22 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-3
- - Match -Z to --context
- * Wed Jan 21 2004 Dan Walsh <dwalsh@redhat.com> 3.1.15-2
- - Add back in -Z support
- * Wed Jan 21 2004 Alexander Larsson <alexl@redhat.com> 3.1.15-1
- - upgrade to procps3
- - Some regressions, see bug #114012
- * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 2.0.17-7
- - Remove LIBCURSES from skill and sysctl
- * Wed Dec 10 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-6
- - Turn on SELinux
- * Mon Dec 8 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-5
- - Fix top total percentages (#109484)
- * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-4
- - Turn off selinux
- * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-3.sel
- - Fix help message
- * Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 2.0.17-2.sel
- - Turn on selinux
- * Fri Oct 3 2003 Alexander Larsson <alexl@redhat.com> 2.0.17-1
- - Update to 2.0.17, drop upstream patches, forward port remaining patches
- * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-11
- - Turn off selinux
- * Thu Aug 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-10.sel
- - Add -Z switch for SELinux
- * Sun Aug 17 2003 Doug Ledford <dledford@redhat.com> 2.0.13-9E
- - Add patch to recognize irq and softirq time accounting in kernels that
- support this feature
- * Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-8
- - rebuild
- * Mon Aug 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-7E
- - Add swapped patch from rik van riel
- * Wed Aug 6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-6
- - rebuild
- * Wed Aug 6 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-5E
- - Update iowait patch (#101657)
- - Add wchan 64bit patch from Mark DeWandel
- * Mon Jul 28 2003 Dan Walsh <dwalsh@redhat.com> 2.0.13-4E
- - Add SELinux patch
- * Wed Jul 16 2003 Matt Wilson <msw@redhat.com> 2.0.13-3E
- - display iowait with procps-2.0.13-iowait.patch (#99061)
- * Fri Jul 11 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-2E
- - Disable linuxthreads thread hack
- * Mon Jul 7 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1E
- - rebuild
- * Fri Jul 4 2003 Alexander Larsson <alexl@redhat.com> 2.0.13-1
- - update to 2.0.13
- - Re-merged ntpl patch
- - Add hertz fix from Ernie Petrides <petrides@redhat.com>
- * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
- - rebuilt
- * Fri May 23 2003 Alexander Larsson <alexl@redhat.com> 2.0.12-1
- - Update to 2.0.12
- - Add patch to fix segfault on ps axl (#91453)
- * Fri Mar 14 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-7
- - Add patch that fixes negative priorities in top.
- * Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-6
- - New NPTL patch:
- - Added skipthreads optimization to top
- - Don't read threads in 'w'
- * Thu Feb 20 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-5
- - Update the NPTL patch since the kernel /proc was fixed
- - For kernels >= 2.4.20-2.50
- * Mon Feb 17 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-4
- - Update nptl patch to new /proc layout.
- * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.11-3
- - rebuilt
- * Wed Jan 22 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-2
- - Created nptl patch after discussion with ingo and arjan
- * Tue Jan 21 2003 Alexander Larsson <alexl@redhat.com> 2.0.11-1
- - Update to 2.0.11
- * Mon Dec 16 2002 Elliot Lee <sopwith@redhat.com> 2.0.10-4
- - Fix %%install in changelog
- * Tue Nov 19 2002 Jakub Jelinek <jakub@redhat.com> 2.0.10-3
- - Fix for Hammer
- * Wed Oct 23 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-2
- - Remove uninstalled files in %%install. Add pmap to %%files
- * Tue Oct 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.10-1
- - Update to 2.0.10
- - Removed applied patches.
- * Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-25
- - Add patch to protect against idle ticks going backwards. Fixes #71237
- * Thu Aug 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-24
- - Fix saving of sort, fixes #32757
- - Fix printing size, fixes #48224
- - Fix float decimal point input #58163
- * Thu Aug 8 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-23
- - Fix unsigned/signed bug. Closes #60998.
- - Update threadbadhack to correctly propagate process time to the main thread.
- * Wed Aug 7 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-22
- - Don't strip binaries
- * Fri Jul 12 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-21
- - Remove the X11 subpackage
- * Mon Jul 1 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-19
- - Added patch that fixes #35174
- * Wed Jun 26 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-18
- - New thread badhack patch. Fixes a segfault.
- * Mon Jun 24 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-16
- - New thread badhack. Now enabled by default.
- * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Thu Jun 20 2002 Alexander Larsson <alexl@redhat.com> 2.0.7-14
- - Added badhack to support hiding threads
- * Thu May 23 2002 Tim Powers <timp@redhat.com>
- - automated rebuild
- * Mon Apr 15 2002 Bill Nottingham <notting@redhat.com> 2.0.7-12
- - add ldconfig in %postun
- * Mon Aug 27 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 2.0.7-11
- - Add ncurses-devel as a build dependency (#49562)
- * Sat Jul 21 2001 Tim Powers <timp@redhat.com>
- - removed applnk entry, one of the things that's cluttering our menus
- * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
- - Bump release + rebuild.
- * Thu Apr 5 2001 Jakub Jelinek <jakub@redhat.com>
- - fix AIX style user defined formats (#34833)
- * Thu Mar 22 2001 Bill Nottingham <notting@redhat.com>
- - add a '-e' to sysctl to ignore errors (#31852)
- * Mon Mar 5 2001 Preston Brown <pbrown@redhat.com>
- - bigger buffer for reading /proc/stat fixes segfault (#27840)
- * Thu Feb 1 2001 Preston Brown <pbrown@redhat.com>
- - make sysctl return a value when errors occur (#18820).
- - support big UIDs (#22683)
- * Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
- - work-around for negative CPU output (Bug #18380)
- * Thu Aug 17 2000 Than Ngo <than@redhat.com>
- - fix failing in RPM post script (Bug #16226)
- * Wed Jul 26 2000 Michael K. Johnson <johnsonm@redhat.com>
- - Added Jakub's locale patch
- * Fri Jul 14 2000 Michael K. Johnson <johnsonm@redhat.com>
- - procps-2.0.7
- - integrated all patches except for signames patch, which is broken
- and unnecessary
- - See NEWS for changes between 2.0.6 and 2.0.7
- - Added patch to correctly install desktop file. Oops.
- * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- - automatic rebuild
- * Mon Jul 03 2000 Preston Brown <pbrown@redhat.com>
- - larger buffers for reading /proc/stat
- * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
- - FHS paths
- * Tue May 30 2000 Preston Brown <pbrown@redhat.com>
- - add smp, signal name patches from VA Linux. Thanks guys.
- * Mon May 22 2000 Harald Hoyer <harald@redhat.com>
- - added sysctl.conf (5) man page
- * Wed May 10 2000 Bill Nottingham <notting@redhat.com>
- - fix PAGE_SIZE mismatch on ia64
- * Sun May 7 2000 Bill Nottingham <notting@redhat.com>
- - rebuild with different optimizations for ia64
- * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
- - rebuild with current ncurses
- * Tue Mar 7 2000 Bill Nottingham <notting@redhat.com>
- - fix end-of-file behavior in sysctl
- * Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
- - wmconfig -> desktop
- * Mon Feb 7 2000 Jakub Jelinek <jakub@redhat.com>
- - don't try to load System.map (and spit error messages if it does not
- exist) if ps or top are not going to use it, both to speed things up
- and remove the ugly messages when they don't make sense.
- - in top, print the possible error messages using standard top SHOWMESSAGE
- (because it will be now printed out when already in terminal mode).
- * Thu Feb 3 2000 Matt Wilson <msw@redhat.com>
- - added patch to prevent divide by zero on UltraSparc
- - gzip man pages
|