sudo-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. Summary: Allows command execution as root for specified users
  2. Summary(ja): スーパーユーザ権限でのコマンドの実行
  3. Name: sudo
  4. Version: 1.8.6p7
  5. Release: 1%{?_dist_release}
  6. License: ISC-style
  7. Group: Applications/System
  8. URL: http://www.sudo.ws/sudo/
  9. Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
  10. Source1: sudo-sudoers-vine
  11. Patch1: sudo-1.6.7p5-strip.patch
  12. Patch4: sudo-1.7.2p1-envdebug.patch
  13. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: pam-devel
  15. BuildRequires: groff
  16. BuildRequires: flex
  17. BuildRequires: bison
  18. BuildRequires: openldap-devel
  19. BuildRequires: automake autoconf libtool
  20. BuildRequires: libcap-devel
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. Sudo (superuser do) allows a system administrator to give certain users
  25. (or groups of users) the ability to run some (or all) commands as root while
  26. logging all commands and arguments. Sudo operates on a per-command basis,
  27. it is not a replacement for the shell.
  28. %description -l ja
  29. sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
  30. いくつかのコマンド操作を行うことを許可するためのプログラムです。
  31. %prep
  32. %setup -q
  33. %patch1 -p1 -b .strip
  34. %patch4 -p1 -b .envdebug
  35. autoreconf -I m4 -fv --install
  36. %build
  37. %configure \
  38. --prefix=%{_prefix} \
  39. --sbindir=%{_sbindir} \
  40. --libdir=%{_libdir} \
  41. --sysconfdir=%{_sysconfdir} \
  42. --docdir=%{_datadir}/doc/%{name}-%{version} \
  43. --with-pam \
  44. --with-pam-login \
  45. --with-logging=syslog \
  46. --with-logfac=authpriv \
  47. --with-tty-tickets \
  48. --with-ignore-dot \
  49. --with-editor=/bin/vi \
  50. --with-env-editor \
  51. --with-ldap \
  52. --with-passprompt="[sudo] password for %p: " \
  53. --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
  54. --without-interfaces \
  55. --without-selinux
  56. make %{?_smp_mflags}
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. mkdir $RPM_BUILD_ROOT
  60. make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
  61. chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
  62. install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
  63. install -p -d -m 750 $RPM_BUILD_ROOT/etc/sudoers.d
  64. install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
  65. chmod +x $RPM_BUILD_ROOT%{_libexecdir}/*.so # for stripping, reset in %%files
  66. # Remove execute permission on this script so we don't pull in perl deps
  67. chmod -x $RPM_BUILD_ROOT%{_docdir}/sudo-*/sudoers2ldif
  68. %find_lang sudo
  69. %find_lang sudoers
  70. cat sudo.lang sudoers.lang > sudo_all.lang
  71. rm sudo.lang sudoers.lang
  72. mkdir -p $RPM_BUILD_ROOT/etc/pam.d
  73. cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
  74. #%PAM-1.0
  75. auth include system-auth
  76. account include system-auth
  77. password include system-auth
  78. session optional pam_keyinit.so revoke
  79. session required pam_limits.so
  80. EOF
  81. cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
  82. #%PAM-1.0
  83. auth include sudo
  84. account include sudo
  85. password include sudo
  86. session optional pam_keyinit.so force revoke
  87. session required pam_limits.so
  88. EOF
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %files -f sudo_all.lang
  92. %defattr(-,root,root)
  93. %doc plugins/sample/sample_plugin.c
  94. %attr(0440,root,root) %config(noreplace) /etc/sudoers
  95. %attr(0750,root,root) %dir /etc/sudoers.d/
  96. %config(noreplace) /etc/pam.d/sudo
  97. %config(noreplace) /etc/pam.d/sudo-i
  98. %dir /var/run/sudo
  99. %attr(4111,root,root) %{_bindir}/sudo
  100. %attr(4111,root,root) %{_bindir}/sudoedit
  101. %attr(4111,root,root) %{_bindir}/sudoreplay
  102. %attr(0755,root,root) %{_sbindir}/visudo
  103. %attr(0644,root,root) %{_libexecdir}/sudo_noexec.so
  104. %attr(0644,root,root) %{_libexecdir}/sudoers.so*
  105. %{_mandir}/man5/sudoers*.5*
  106. %{_mandir}/man8/sudo.8*
  107. %{_mandir}/man8/sudoedit.8*
  108. %{_mandir}/man8/sudoreplay.8*
  109. %{_mandir}/man8/visudo.8*
  110. %dir %{_docdir}/sudo-%{version}
  111. %{_docdir}/sudo-%{version}/*
  112. # should be splitted to -devel?
  113. %{_includedir}/sudo_plugin.h
  114. %{_mandir}/man8/sudo_plugin.8*
  115. %post
  116. /bin/chmod 0440 /etc/sudoers || :
  117. %changelog
  118. * Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
  119. - update to 1.8.6p7
  120. - drop unneeded patches.
  121. * Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
  122. - add patch120 for fix CVE-2012-2337 (netmask match)
  123. * Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
  124. - update sudoers
  125. - enable "%wheel ALL=(ALL) ALL" by default.
  126. * Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
  127. - add patch110,111 for fix CVE-2011-0010 ("-g" option)
  128. * Wed Sep 8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
  129. - add Patch100 for fix CVE-2010-2956 (sudo Runas)
  130. - add _smp_mflags flag into make section
  131. - fix doc filelist (no longer exist BUGS, CHANGSE)
  132. * Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
  133. - new upstream release with security fix (CVE-2010-1646)
  134. - change specfile name (-vl)
  135. * Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
  136. - new upstream release with security fix (CVE-2010-1163)
  137. - add sudoers.ldap.5 into files section
  138. * Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
  139. - new upstream release with security fix (CVE-2010-0426)
  140. - update Patch3
  141. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
  142. - new upstream release
  143. * Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
  144. - new upstream release
  145. - update patches
  146. - disable "Defaults requiretty"
  147. * Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
  148. - rebuilt with openldap-2.4.11
  149. * Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
  150. - new upstream release with security fix (CVE 2009-0034)
  151. * Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
  152. - new upstream release
  153. - merge some changes from fedoraproject
  154. - include [sudo] in password prompt
  155. - compiled with secure path
  156. - also use getgrouplist() to determine group membership
  157. - add sudoers file
  158. - add command aliases, default environment config
  159. - build with openldap
  160. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
  161. - applied new versioning policy, spec in utf-8
  162. * Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
  163. - change PAM configuration to use system-auth
  164. - add --with-ignore-dot, --with-editor and --with-env-editor to
  165. configure option.
  166. * Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
  167. - new upstream release (included security fix)
  168. - add patch1 for fix CVE-2006-0151
  169. * Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
  170. - new upstream release
  171. - use macros
  172. - build with pam
  173. * Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
  174. - new upstream release
  175. * Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
  176. - SECURITY FIX: new upstream release
  177. - update rpmnonroot.patch ( Patch0 )
  178. - add new man page: sudoedit(8)
  179. * Wed Sep 1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
  180. - new upstream release
  181. - update rpmnonroot.patch ( Patch0 )
  182. - change Copyrigh tag to License tag
  183. - update License
  184. - update URL and Source0: official web site moved.
  185. - new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
  186. * Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
  187. - upstream release
  188. * Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
  189. - fixed changelog
  190. -- don't expand macros in changelog ;P
  191. * Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
  192. - changed to use configure in build section
  193. (can't build on sparc)
  194. * Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
  195. - upstream release
  196. - fix security hole : buffer over flow
  197. * Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
  198. - upstream release
  199. - updated sudo.rpmnonroot.diff
  200. * Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
  201. - upstream release
  202. - added configure script option '--disable-root-mailer'
  203. * Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
  204. - upstream release
  205. - eliminated FAQ from %doc
  206. * Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
  207. - upstream release
  208. - added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
  209. - updated sudo.rpmnonroot.diff
  210. * Wed May 09 2001 <sagami@vinelinux.org>
  211. - 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
  212. * Fri Mar 02 2001 sagami@vinelinux.org
  213. - 1.6.3p7-0vl1
  214. - use better macros
  215. * Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
  216. - 1.6.3p6-0vl1
  217. - changed sudo.rpmnonroot.diff for 1.6.3p6
  218. * Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  219. - 1.6.1-2vl5
  220. - patch -p1 -> patch -p0
  221. * Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
  222. - 1.6.1-2vl4
  223. - fix uid/gid to root.root
  224. - add sudo.rpmnonroot.diff to built by non-root users
  225. * Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
  226. - 1.6.1-2vl3
  227. - fix attr
  228. * Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
  229. - 1.6.1-2vl2
  230. - enable to build by non-root useres
  231. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  232. - 1.6.1-2vl1
  233. - modified %files section to handle compressed man page(s)
  234. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  235. - change group
  236. * Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
  237. - version 1.6.1
  238. - build for Vine Linux 2.0
  239. * Fri May 14 1999 Takeda Eiji <keda@flatout.org>
  240. - sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
  241. * Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
  242. - Initial Release