123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158 |
- Name: drumstick
- Summary: Qt4/C++ wrapper for ALSA sequencer
- Version: 0.5.0
- Release: 2%{?_dist_release}
- Group: System Environment/Libraries
- License: GPLv2+
- URL: http://drumstick.sourceforge.net/
- Source0: http://downloads.sourceforge.net/project/drumstick/%{version}/drumstick-%{version}.tar.bz2
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: cmake
- BuildRequires: qt4-devel
- BuildRequires: alsa-lib-devel
- BuildRequires: desktop-file-utils
- BuildRequires: docbook-style-xsl
- Obsoletes: aseqmm < %{version}-%{release}
- Provides: aseqmm = %{version}-%{release}
- Requires(post): shared-mime-info
- Requires(post): /sbin/ldconfig
- Requires(postun): shared-mime-info
- Requires(postun): /sbin/ldconfig
- %description
- The drumstick library is a C++ wrapper around the ALSA library sequencer
- interface, using Qt4 objects, idioms and style. The ALSA sequencer interface
- provides software support for MIDI technology on GNU/Linux.
- %package devel
- Summary: Developer files for %{name}
- Summary(ja): %{name} の開発用ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Obsoletes: aseqmm-devel < %{version}-%{release}
- Provides: aseqmm-devel = %{version}-%{release}
- %description devel
- %{summary}.
- %package examples
- Summary: Example programs for %{name}
- Group: System Environment/Libraries
- Requires: %{name} = %{version}-%{release}
- Obsoletes: aseqmm-examples < %{version}-%{release}
- Provides: aseqmm-examples = %{version}-%{release}
- %description examples
- This package contains the test/example programs for %{name}.
- %prep
- %setup -q -n %{name}-%{version}%{?svn}
- #patch0 -p1 -b .implicit-linking
- #patch1 -p0 -b .sysinfo-#597354
- %build
- mkdir -p %{_target_platform}
- pushd %{_target_platform}
- %cmake ..
- popd
- make %{?_smp_mflags} -C %{_target_platform}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
- for i in $RPM_BUILD_ROOT%{_datadir}/applications/* ; do
- desktop-file-validate $i
- done
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- update-mime-database %{_datadir}/mime &> /dev/null || :
- %postun
- /sbin/ldconfig
- update-mime-database %{_datadir}/mime &> /dev/null || :
- %post examples
- touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
- update-desktop-database &> /dev/null || :
- %postun examples
- update-desktop-database &> /dev/null || :
- if [ $1 -eq 0 ] ; then
- touch --no-create %{_datadir}/icons/hicolor &>/dev/null
- gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
- fi
- %posttrans examples
- gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
- %files
- %defattr(-,root,root,-)
- %doc ChangeLog COPYING
- %{_libdir}/libdrumstick-file.so.*
- %{_libdir}/libdrumstick-alsa.so.*
- %{_datadir}/mime/packages/drumstick.xml
- %files devel
- %defattr(-,root,root,-)
- %{_libdir}/libdrumstick-file.so
- %{_libdir}/libdrumstick-alsa.so
- %{_libdir}/pkgconfig/drumstick-file.pc
- %{_libdir}/pkgconfig/drumstick-alsa.pc
- %{_includedir}/drumstick/
- %{_includedir}/drumstick.h
- %files examples
- %defattr(-,root,root,-)
- %{_bindir}/drumstick-*
- %{_datadir}/applications/drumstick-*.desktop
- %{_datadir}/icons/hicolor/*/apps/*
- %{_mandir}/man1/*
- %changelog
- * Sat May 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.0-2
- - BuildRequires: docbook-style-xsl
- * Sat Jan 15 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.5.0-1
- - Initial build for Vine Linux
- * Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.3.1-2
- - sysinfo: don't crash when no timer module available (#597354, upstream patch)
- * Fri May 28 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.3.1-1
- - update to 0.3.1
- - fix FTBFS due to the strict ld in Fedora >= 13
- * Mon Mar 15 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.3.0-1
- - update to 0.3.0 release
- * Tue Feb 08 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.99-0.3.svn20100208
- - update from SVN for KMid2 0.2.1
- * Sun Jan 31 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.99-0.2.svn20100107
- - put the alphatag before the disttag
- * Fri Jan 29 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.99-0.1.svn20100107
- - update to 0.2.99svn tarball
- - renamed from aseqmm to drumstick by upstream
- * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-2
- - require the main package with exact version-release in -examples
- * Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.2.0-1
- - First Fedora package
|