lmdb-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220
  1. # The files themselves are in several subdirectories and need to be prefixed wit this.
  2. %global archive_path libraries/lib%{name}
  3. Name: lmdb
  4. Version: 0.9.29
  5. Release: 1%{?_dist_release}
  6. Summary: Memory-mapped key-value database
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: OpenLDAP
  11. URL: http://symas.com/mdb/
  12. Source0: https://github.com/LMDB/lmdb/archive/LMDB_%{version}.tar.gz
  13. Source1: lmdb.pc.in
  14. # Patch description in the corresponding file
  15. Patch0: lmdb-make.patch
  16. Patch1: lmdb-s390-check.patch
  17. BuildRequires: make
  18. BuildRequires: gcc
  19. BuildRequires: doxygen
  20. %description
  21. LMDB is an ultra-fast, ultra-compact key-value embedded data
  22. store developed by Symas for the OpenLDAP Project. By using memory-mapped files,
  23. it provides the read performance of a pure in-memory database while still
  24. offering the persistence of standard disk-based databases, and is only limited
  25. to the size of the virtual address space.
  26. %package libs
  27. Summary: Shared libraries for %{name}
  28. Group: system
  29. %description libs
  30. The %{name}-libs package contains shared libraries necessary for running
  31. applications that use %{name}.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Requires: %{name}%{?_isa} = %{version}-%{release}
  35. Group: programming
  36. %description devel
  37. The %{name}-devel package contains libraries and header files for
  38. developing applications that use %{name}.
  39. %package doc
  40. Summary: Documentation files for %{name}
  41. BuildArch: noarch
  42. Group: documentation
  43. %description doc
  44. The %{name}-doc package contains automatically generated documentation for %{name}.
  45. %debug_package
  46. %prep
  47. %setup -q -n %{name}-LMDB_%{version}
  48. %patch0 -p1 -b .make
  49. %patch1 -p1 -b .s390-check
  50. %build
  51. pushd %{archive_path}
  52. %set_build_flags
  53. make %{?_smp_mflags} XCFLAGS="%{build_cflags}"
  54. # Build doxygen documentation
  55. doxygen
  56. # remove unpackaged files
  57. rm -f Doxyfile
  58. rm -rf man # Doxygen generated manpages
  59. popd
  60. %install
  61. pushd %{archive_path}
  62. # make install expects existing directory tree
  63. mkdir -m 0755 -p %{buildroot}{%{_bindir},%{_includedir}}
  64. mkdir -m 0755 -p %{buildroot}{%{_libdir}/pkgconfig,%{_mandir}/man1}
  65. make DESTDIR=%{buildroot} prefix=%{_prefix} libdir=%{_libdir} mandir=%{_mandir} install
  66. popd
  67. # Install pkgconfig file
  68. sed -e 's:@PREFIX@:%{_prefix}:g' \
  69. -e 's:@EXEC_PREFIX@:%{_exec_prefix}:g' \
  70. -e 's:@LIBDIR@:%{_libdir}:g' \
  71. -e 's:@INCLUDEDIR@:%{_includedir}:g' \
  72. -e 's:@PACKAGE_VERSION@:%{version}:g' \
  73. %{SOURCE1} >lmdb.pc
  74. install -Dpm 0644 -t %{buildroot}%{_libdir}/pkgconfig lmdb.pc
  75. %check
  76. pushd %{archive_path}
  77. rm -rf testdb
  78. LD_LIBRARY_PATH=$PWD make test
  79. popd
  80. %files
  81. %{_bindir}/*
  82. %{_mandir}/man1/*
  83. %files libs
  84. %doc %{archive_path}/COPYRIGHT
  85. %doc %{archive_path}/CHANGES
  86. %license %{archive_path}/LICENSE
  87. %{_libdir}/*.so.*
  88. %files devel
  89. %{_includedir}/*
  90. %{_libdir}/*.so
  91. %{_libdir}/pkgconfig/*.pc
  92. %files doc
  93. %doc %{archive_path}/html
  94. %doc %{archive_path}/COPYRIGHT
  95. %doc %{archive_path}/CHANGES
  96. %license %{archive_path}/LICENSE
  97. %changelog
  98. * Tue May 31 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.29-1
  99. - new upstream release.
  100. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.24-1
  101. - initial build for Vine Linux.
  102. - new upstream release.
  103. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.23-3
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  105. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.23-2
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  107. * Wed Jan 09 2019 Tomas Krizek <tomas.krizek@nic.cz> - 0.9.23-1
  108. - Updated to 0.9.23
  109. * Mon Nov 05 2018 Jan Staněk <jstanek@redhat.com> - 0.9.22-4
  110. - Import upstream fix for rhbz#1645114
  111. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.22-3
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  113. * Mon Apr 23 2018 Florin Asavoaie <florin.asavoaie@gmail.com> - 0.9.22-2
  114. - Fixed Build Dependencies
  115. - Made build work on CentOS 7 for EPEL
  116. * Tue Apr 10 2018 Jan Staněk <jstanek@redhat.com> - 0.9.22-1
  117. - Updated to 0.9.22
  118. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-4
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  120. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  122. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.21-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  124. * Fri Jun 02 2017 Jan Stanek <jstanek@redhat.com> - 0.9.21-1
  125. - Update to 0.9.21
  126. * Mon Mar 20 2017 Jan Stanek <jstanek@redhat.com> - 0.9.20-3
  127. - Add pkgconfig file to devel subpackage
  128. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.20-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  130. * Thu Jan 12 2017 Jan Stanek <jstanek@redhat.com> - 0.9.20-1
  131. - Update to 0.9.20
  132. * Wed Jan 04 2017 Jan Stanek <jstanek@redhat.com> - 0.9.19-1
  133. - Update to 0.9.19
  134. * Wed Feb 10 2016 Jan Stanek <jstanek@redhat.com> - 0.9.18-1
  135. - Update to 0.9.18
  136. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.17-3
  137. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  138. * Mon Dec 28 2015 Jan Vcelak <jvcelak@fedoraproject.org> 0.9.17-2
  139. - Make liblmdb.so a symbolic link to (not a copy of) the versioned DSO
  140. * Thu Dec 03 2015 Jan Staněk <jstanek@redhat.com> - 0.9.17-1
  141. - Update to 0.9.17
  142. * Wed Nov 25 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-2
  143. - Return the name 'Symas' into description
  144. * Fri Aug 14 2015 Jan Staněk <jstanek@redhat.com> - 0.9.16-1
  145. - Updated to 0.9.16
  146. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.14-2
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  148. * Thu Dec 11 2014 Jan Staněk <jstanek@redhat.com> - 0.9.14-1
  149. - Updated to 0.9.14
  150. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.13-2
  151. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  152. * Fri Jul 18 2014 Jan Stanek <jstanek@redhat.com> - 0.9.13-1
  153. - Updated to 0.9.13
  154. * Mon Jul 14 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-4
  155. - Changed install instruction to be compatible with older coreutils (#1119084)
  156. * Thu Jun 26 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-3
  157. - Added delay in testing which was needed on s390* arches (#1104232)
  158. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.11-2
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  160. * Tue May 27 2014 Jan Stanek <jstanek@redhat.com> - 0.9.11-1
  161. - Initial Package