Summary: Python Distribution Utilities
Name: Distutils
Version: 1.0.2
Release: 1vl1
Source: http://www.python.org/sigs/distutils-sig/download/Distutils-%{version}.tar.gz
Patch: Distutils-1.0.2-docfiles.patch
License: Python
Requires: python
Buildrequires: python 
Group: Development/Libraries
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
BuildArchitectures: noarch
URL: http://www.python.org/sigs/distutils-sig/

%description
A collection of modules to aid in the distribution and installation of
Python modules, extensions, and (ultimately) applications.  A standard
part of Python 1.6 and 2.0, but also distributed separately for use with
Python 1.5.

%prep
%setup

%patch0 -p1

%build
python setup.py build

%install
rm -fr $RPM_BUILD_ROOT
python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES

%clean
rm -rf $RPM_BUILD_ROOT

%files -f INSTALLED_FILES
%defattr(-,root,root)
%doc CHANGES.txt README.txt USAGE.txt doc/ examples/

%changelog
* Fri Feb  1 2002 Jun Nishii <jun@vinelinux.org> 1.0.2-0vl1
- rebuild for Vine Linux

* Fri Jun  1 2001 Trond Eivind Glomsr�d <teg@redhat.com>
- 1.0.2
- Add patch from alane@geeksrus.net for bdist_rpm

* Fri Dec 01 2000 Trond Eivind Glomsr�d <teg@redhat.com>
- rebuild

* Thu Nov 02 2000 Trond Eivind Glomsr�d <teg@redhat.com>
- cleaned up the specfile, remove unnecesarry macros.

* Thu Jun 29 2000 Greg Ward <gward@python.net> 0.9
- Made myself the packager, since I can now create the RPM on my own

* Sun Jun 04 2000 Harry Henry Gebel <hgebel@inet.net> 0.9pre-1
- Made sure scripts are file names, filled in some help strings, formatted
  changelog correctly

* Wed May 31 2000 Greg Ward <gward@python.net> 0.8.3pre-1
- Hacked up bdist_rpm.py, moved meta-data into setup.cfg

* Thu May 10 2000 Harry Henry Gebel <hgebel@inet.net> 0.8.2-3
- Added new options to package_data

* Tue May 09 2000 Harry Henry Gebel <hgebel@inet.net> 0.8.2-2
- Include RPM_OPT_FLAGS in distutils

* Wed Apr 26 2000 Harry Henry Gebel <hgebel@inet.net> 0.8.2-1
- First test of bdist_rpm